Bug 88269 - ATI Rage Mobility redhat-config-xfree86 creates bad /etc/X11/XF86Config
ATI Rage Mobility redhat-config-xfree86 creates bad /etc/X11/XF86Config
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 10:31 EDT by adam allen
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 14:55:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam allen 2003-04-08 10:31:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Relating to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=82141 


During install of shrike, it believes that the maximum resolution of the card
(ATI-Rage Mobility) is 800x600; it is infact 1024x768.

After installation using redhat-config-xfree86 the maximum resolution supported
can be selected upto 1920x1440, I'm guessing this drop-down box doesn't really
know the underlying hardware capabilities.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Dell Latitude L400 (ATI Rage Mobility) 
2. Install, set resolution to 800x600 during install
3. Use redhat-config-xfree86 to change resolution to 1024x768
    

Actual Results:  /etc/X11/XF86Config 
        SubSection "Display"
                Depth     16
                Modes    "800x600" "640x480"
        EndSubSection

User can set any resolution in redhat-config-xfree86; it is ignored.

Expected Results:  /etc/X11/XF86Config 
        SubSection "Display"
                Depth     16
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection


Additional info:

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x
(rev 64)
Comment 1 adam allen 2003-04-13 12:51:17 EDT
This behaviour was also found on an Nvidia Geforce 2 card.
Comment 2 Brent Fox 2003-06-02 14:28:12 EDT
The behavior that you're seeing in the installer is most likely because the
installer could not probe the LCD monitor.  I suspect that if you picked
"Generic Laptop Display Panel 1024x768" in the monitor list, you would have seen
a resolution option for 1024x768.
Comment 3 Brent Fox 2003-06-02 14:46:41 EDT
Also, a workaround for this bug is to go into the monitor dialog in
redhat-config-xfree86 and select the Generic Laptop Display 1024x768 monitor. 
That should allow the 1024x768 resolution setting to take place.
Comment 4 Brent Fox 2003-09-11 14:55:58 EDT
I am unable to reproduce this on my Compaq Presario 1700T, which has an ATI Rage
Mobility video chipset.  Closing as 'worksforme'

Note You need to log in before you can comment on or make changes to this bug.