Bug 882722 - 'KeyError: None' while trying to install F18 beta
'KeyError: None' while trying to install F18 beta
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:adb0a6949615f36bf44a25a4902...
: Reopened
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-02 17:43 EST by Eric Blake
Modified: 2012-12-12 00:57 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 00:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (3.48 MB, text/plain)
2012-12-02 17:43 EST, Eric Blake
no flags Details
File: environ (883 bytes, text/plain)
2012-12-02 17:43 EST, Eric Blake
no flags Details
File: type (9 bytes, text/plain)
2012-12-02 17:43 EST, Eric Blake
no flags Details
File: ifcfg.log (1.31 KB, text/plain)
2012-12-02 17:43 EST, Eric Blake
no flags Details
File: storage.log (1.95 MB, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: version (2 bytes, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: program.log (726.05 KB, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: executable (14 bytes, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: product (6 bytes, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: anaconda.log (299.06 KB, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: cmdline_file (149 bytes, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: release (33 bytes, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details
File: messages (503.09 KB, text/plain)
2012-12-02 17:44 EST, Eric Blake
no flags Details

  None (edit)
Description Eric Blake 2012-12-02 17:43:32 EST
Description of problem:
Trying to install F18 beta onto a disk that I have already pre-partitioned, and using custom partitioning to try and associate those pre-existing partitions to what I want used for F18.

Version-Release number of selected component:
anaconda-18.34-1.fc18.x86_64

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.34 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1679, in _populate_right_side
:    typeCombo.set_active(type_index_map[device_type])
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1287, in _save_right_side
:    self._populate_right_side(selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2162, in on_page_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 119, in _onExpanded
:    cb(obj.get_child())
:KeyError: None
Comment 1 Eric Blake 2012-12-02 17:43:54 EST
Created attachment 656264 [details]
File: anaconda-tb
Comment 2 Eric Blake 2012-12-02 17:43:56 EST
Created attachment 656265 [details]
File: environ
Comment 3 Eric Blake 2012-12-02 17:43:58 EST
Created attachment 656266 [details]
File: type
Comment 4 Eric Blake 2012-12-02 17:43:59 EST
Created attachment 656267 [details]
File: ifcfg.log
Comment 5 Eric Blake 2012-12-02 17:44:11 EST
Created attachment 656268 [details]
File: storage.log
Comment 6 Eric Blake 2012-12-02 17:44:13 EST
Created attachment 656269 [details]
File: version
Comment 7 Eric Blake 2012-12-02 17:44:18 EST
Created attachment 656270 [details]
File: program.log
Comment 8 Eric Blake 2012-12-02 17:44:19 EST
Created attachment 656271 [details]
File: executable
Comment 9 Eric Blake 2012-12-02 17:44:21 EST
Created attachment 656272 [details]
File: product
Comment 10 Eric Blake 2012-12-02 17:44:24 EST
Created attachment 656273 [details]
File: anaconda.log
Comment 11 Eric Blake 2012-12-02 17:44:25 EST
Created attachment 656274 [details]
File: hashmarkername
Comment 12 Eric Blake 2012-12-02 17:44:26 EST
Created attachment 656275 [details]
File: cmdline_file
Comment 13 Eric Blake 2012-12-02 17:44:28 EST
Created attachment 656276 [details]
File: release
Comment 14 Eric Blake 2012-12-02 17:44:32 EST
Created attachment 656277 [details]
File: messages
Comment 15 Eric Blake 2012-12-03 16:43:52 EST
Proposing as F18 final blocker, since I was unable to install while reusing an LVM partition from a LUKS-encrypted volume group.
Comment 16 Jared Smith 2012-12-04 15:40:13 EST
I was using Anaconda to re-use some logical volumes from a previous installation.  That part worked fine, but when I went back and clicked on the + sign next to the Fedora 18 volumes/mount points/whatever you want to call them, it crashed :-(

Package: anaconda-18.34-1.fc18.x86_64
OS Release: Fedora release 18
Comment 17 Jared Smith 2012-12-04 15:42:20 EST
Please let me know if you want any of my log files, and I'll attach them.  (I see that some one else already attached theirs, so I won't duplicate logs unless someone tells me that they're useful.)
Comment 18 Tim Flink 2012-12-04 16:21:32 EST
I believe that the criterion in question here is from the F18 final release criteria [1]:

The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above.

[1] http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 19 Paul Franklin (RHlists) 2012-12-05 12:01:54 EST
+1 Final blocker.

The criterion sounds like it is being met to me.
Comment 20 Adam Williamson 2012-12-05 13:30:43 EST
Discussed at 2012-12-05 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-05/f18final-blocker-review-2.2012-12-05-17.01.log.txt . We feel like this is very likely a blocker bug, but we'd just like to be sure of the circumstances that trigger it first. If either reporter or the anaconda team can determine the precise trigger for this - is it any re-use of existing LVs? Encrypted ones only? - we'll be able to make a definite determination.
Comment 21 Jared Smith 2012-12-05 13:59:47 EST
In my case, I tried to re-use encrypted LVM logical volumes.  

As I remember it, as I went in and gave the LVs their label and/or mount point, they appeared on the tree view on the left-hand pane of the installation window.  It was when I went to expand the list of *new* (partitions? mount points? volumes?) at the top of the left-hand pane that things exploded.

If I get time this afternoon, I'll try to reproduce it again.
Comment 22 David Lehman 2012-12-05 14:47:33 EST
I have a patch here I'll be testing soon.
Comment 23 Fedora Update System 2012-12-05 20:55:06 EST
anaconda-18.36-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.36-1.fc18
Comment 24 Fedora Update System 2012-12-06 15:17:35 EST
Package anaconda-18.36-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.36-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19870/anaconda-18.36-1.fc18
then log in and leave karma (feedback).
Comment 25 Fedora Update System 2012-12-07 23:30:21 EST
anaconda-18.36-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Adam Williamson 2012-12-08 12:54:58 EST
This got closed pretty fast, it'd be nice to have verification from the reporters that it's fixed. Jared, Eric - 18.36 is in Final TC1, so can you check with that? Thanks!
Comment 27 Eric Blake 2012-12-09 00:43:52 EST
I'm planning on testing it Monday, when I have the time...
Comment 28 Kamil Páral 2012-12-10 04:17:09 EST
David, do you have some simple reproducer so that anyone can test it?
Comment 29 David Lehman 2012-12-10 11:28:08 EST
As I recall, the following should reproduce it:

 1. do an encrypted autopart install
 2. start another install
 3. enter custom storage spoke
 4. decrypt PVs from previous install
 5. select any of the LVs from the previous install
 6. activate "Reformat"
 7. click "Apply Changes"
 8. click on the same LV under the "New Fedora" subtree

I'm not sure if 8 is necessary or not. If it hasn't crashed yet when you get to it, do it as well.
Comment 30 Adam Williamson 2012-12-10 14:46:47 EST
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . Accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" in the case of re-using existing encrypted PVs.
Comment 31 Eric Blake 2012-12-10 16:04:40 EST
(In reply to comment #29)
> As I recall, the following should reproduce it:
> 
>  1. do an encrypted autopart install
>  2. start another install
>  3. enter custom storage spoke
>  4. decrypt PVs from previous install
>  5. select any of the LVs from the previous install
>  6. activate "Reformat"
>  7. click "Apply Changes"
>  8. click on the same LV under the "New Fedora" subtree
> 
> I'm not sure if 8 is necessary or not. If it hasn't crashed yet when you get
> to it, do it as well.

Yes, that matches what I recall when I saw the crash.  In the meantime, I upgraded to anaconda 18.37, and retried, and this time was successful.  Looks like you did indeed fix it.
Comment 32 Adam Williamson 2012-12-12 00:57:56 EST
So since the fix was in 18.36 and that went stable, let's close this.

Note You need to log in before you can comment on or make changes to this bug.