Bug 8828 - When the usrquota,grpquota options are added to the fstab, the box can and will lock up.
When the usrquota,grpquota options are added to the fstab, the box can and wi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-25 00:41 EST by markm
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-25 00:41:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2000-01-25 00:41:02 EST
There seems to be a problem with enabling quotas on RH6.0.  I have tried
this on two different boxes and have had similiar results.

What I do is edit the /etc/fstab to put in grpquota on the partition I want
to enable quotas on, and then I (as root) create the quota.group in the
root directory of that parititon.
After that, what happens is extremely annoying.  When accessing quotas
(edquota), displaying quotas (repquota) or even creating users
(/usr/sbin/useradd), the system seems to hang up.

It is wedged so bad that I can't even log in using another window to kill
the repquota (e.g.) command -- the system displays login/password, but
never forks off the shell.  Also, ^c and ^z have no effect.

The only way to clear the problem is to hit the 'reset' button, since
there's no way to log in.

The problem seems to be related to validating users -- while /bin/login has
no problem running to show the 'login: ' and 'Password: ' prompts, it never
gets to create the shell.  Same for /usr/sbin/useradd -- the system locked
up when I tried to run that command with quotas enabled.

On the remote system that I maintain, I edited /etc/fstab to remove the
grpquota option from the partition entry, and I typed 'init 6', but the box
never came back up.  I've got a feeling that it's still trying to shut down
(and got wedged somewhere).

Tomorrow I'll have my ISP reset the box and I'll see if I can lock up the
system again now that quota is off.

Thanks for taking the time to read all this....

  - Mark Musante
    Epic Verse Software, Inc.
    markm@multiuser.net
Comment 1 Preston Brown 2001-02-01 17:59:01 EST
quotas work fine with at least Red Hat Linux 6.2 and later.

Remember, to create quota.user or quota.group, you have to add either usrquota
or grpquota to the proper /etc/fstab line, and then run /usr/sbin/quotacheck
<device>.  Don't create any files by hand.

Note You need to log in before you can comment on or make changes to this bug.