Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 882829 - [Doc] Perl-Sys-Virt doc for list_all_volumes have errors
Summary: [Doc] Perl-Sys-Virt doc for list_all_volumes have errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Sys-Virt
Version: 6.4
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 886216
TreeView+ depends on / blocked
 
Reported: 2012-12-03 08:06 UTC by weizhang
Modified: 2013-02-21 09:52 UTC (History)
4 users (show)

Fixed In Version: perl-Sys-Virt-0.10.2-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: Mistakes were made in the POD documentation for list_all_volumes Consequence: The documentation would mislead users Fix: The documentation was updated Result: The documentation for list_all_volumes correctly describes the API usage
Clone Of:
Environment:
Last Closed: 2013-02-21 09:52:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0377 0 normal SHIPPED_LIVE perl-Sys-Virt bug fix and enhancement update 2013-02-20 20:52:18 UTC

Description weizhang 2012-12-03 08:06:02 UTC
Description of problem:
in /usr/share/man/man3/Sys::Virt::StoragePool.3pm.gz
for list_all_volumes, it list

my @volumes = $dom->list_all_volumes($flags)
   Return a list of all storage volumes associated with this domain. The elements in the returned list are instances of the Sys::Virt::StorageVol class. The $flags parameter can be used to filter the list of return storage volumes.

But it real test, list_all_volumes belongs to pool object but not domain, and it list all volumes in pool but not in domain. And now the flag only can be set to 0, so the doc need to be updated

Also for  
  my @nets = $pool->list_volumes()

the return parameter better to set to @volumes but not @nets

Version-Release number of selected component (if applicable):
perl-Sys-Virt-0.10.2-4.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Berrangé 2012-12-11 10:57:23 UTC
commit 1bc198f982e7749661ccf9071c5ee6669ba7e09b
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue Dec 11 10:57:02 2012 +0000

    Fix misc typos in POD docs for StoragePool.pm
    
    Signed-off-by: Daniel P. Berrange <berrange@redhat.com>

Comment 3 weizhang 2012-12-13 12:31:56 UTC
Verify pass on
perl-Sys-Virt-0.10.2-5.el6.x86_64

check doc
my @vols = $pool->list_volumes()
           Return a list of all volumes in the storage pool.  The elements in the returned list are instances of the
           Sys::Virt::StorageVol class. This method requires O(n) RPC calls, so the "list_all_volumes" method is recommended
           as a more efficient alternative.

my @volumes = $pool->list_all_volumes($flags)
           Return a list of all storage volumes associated with this pool.  The elements in the returned list are instances of
           the Sys::Virt::StorageVol class. The $flags parameter can be used to filter the list of return storage volumes.

Comment 5 errata-xmlrpc 2013-02-21 09:52:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0377.html


Note You need to log in before you can comment on or make changes to this bug.