Bug 88297 - Linux not recognizing a minidisk any size other than 1000 cylinders.
Linux not recognizing a minidisk any size other than 1000 cylinders.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 13:25 EDT by Mike Gahagan
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-30 13:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2003-04-08 13:25:32 EDT
Description of problem:

More info to follow, This is from IT# 18332

Summary:     231892 - 1000 cylinders per disk
Opened By:   erondolo
Assigned To: mgahagan@redhat.com
Severity:    High

Red Hat Linux for S/390 (Basic)

Customer 468961


We have been defining a number of RED Hat Machines under VM on an S390 box. The 
problem we seem to run into is that unless we define a disk with 1000 cylinders 
the RH linux software doesn't recognize it. This is a big waste of space.
Did  you know that this bug existed and do you have a fix for it.  Thanks

****** EVENT ******

Hello,

I am not aware of any sort of bug relating to a dasd having to be exactly 1000
cylinders, I have looked over a few of our internal VM's for testing and a
number of them are using dasd of sizes not exactly set at 1000 cylinders. Please
forward me the following information:

What is the exact error message you receive and where is it coming from? i.e.
are you getting errors from the installer or prior to starting it?

Which release are you using? (/etc/redhat-release on an already installed system
or you can look at the initial startup screen in the installer)

Output from any virtual terminals or logs related to this.

What installation method is being used? (local media, NFS, FTP etc.)

How are you partitioning the dasd you are providing to the linux OS.

****** EVENT ******

let me clear this up a bit. We try to create a mdisk on vm with
less than 1000 cycls and Linux would not recongize it. We tried
100, 200, 300, 400, 500, 600 they did no work, then 1000 and it work. There is 
is no error message, it just doesn't mount on linux. We discovered this
when we were doing the install with your techie. We think this is
a bug. Try defining 100 minidisk on VM. ipl 292 and see if it show up.
Thanks for your support.


Status set to: Waiting on Tech


****** EVENT ******

We currently have 2 S/390 releases, please let me know which you are using (see
previous event in the ticket)

Is the Red Hat Linux instance already installed and you are attempting to give
it additional storage by defining a minidisk inside of the VM and subsequently
booting the linux instance then attempting to use the new minidisk by running
fdasd on it and then running mke2fs to put a filesystem on it? Or have you
defined minidisk storage in VM and are attempting to install to it?

If you are installing for the first time, is the install program starting when
you start the loader (after the ipl)?

It is very ususual that you are not getting any error messages anywhere when
this is happening, it is possible that there might be some error messages that
are overlooked?

Please give us the details of the hardware of this system. If you can get me the
name of the Red Hat consultant that helped you set this up let me know, its
likely I can get some information about this from him.






Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Karsten Hopp 2003-04-11 17:27:28 EDT
It looks like you're hitting a bug?? in e2fsutils. Partitions with less than
512MB will be formatted with blocksize 1024. As far as my testing shows, only 
blocksize 4096 is supported. Please format your partition with 'mke2fs -b 4096'
and don't rely on the default setting.
Please close the bug if this fixes the problem.
Comment 2 Mike Gahagan 2003-04-11 17:38:26 EDT
Right now, it appears that Linux doesn't even see the device, so there is
nothing to mke2fs. More info should follow early next week.

Comment 3 Karsten Hopp 2003-04-16 04:51:02 EDT
Any news here ?
Btw, the report isn't really clear about what's wrong.  There is:

- it just doesn't mount on linux   (that's the mke2fs bug)
- Linux would not recognize it     

Which one is true ?  

Does 'cat /proc/dasd/devices' show the new device ?
Did they format it at all ?  With dasdfmt AND mke2fs ?
How did they format it ?  dasdfmt -d cdl   or dasdfmt -d ldl ?


Comment 4 Karsten Hopp 2003-04-30 04:43:35 EDT
can we close this report ?
Comment 5 Mike Gahagan 2003-04-30 13:54:53 EDT
I haven't heard anything from the client in over 3 weeks now.. closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.