Bug 882995 - Unfence reference isn't updated when fence device gets renamed
Summary: Unfence reference isn't updated when fence device gets renamed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 888457
TreeView+ depends on / blocked
 
Reported: 2012-12-03 15:20 UTC by Radek Steiger
Modified: 2013-02-21 08:23 UTC (History)
1 user (show)

Fixed In Version: luci-0.26.0-35.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:23:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0309 normal SHIPPED_LIVE luci bug fix and enhancement update 2013-02-20 20:35:24 UTC

Description Radek Steiger 2012-12-03 15:20:59 UTC
Description of problem:
When you rename a fencing device that is referenced within an instance with Unfence enabled, the Unfence reference does not get updated with the new name and will refer to a non-existent device.



Version-Release number of selected component (if applicable):
luci-0.26.0-29.el6.i686


How reproducible:
Always


Steps to Reproduce:

1. Create a new fencing device

2. On a selected cluster node, define a new fencing method + instance with Unfence enabled
The cluster.conf snippet will look like this: 
<clusternode name="z2" nodeid="1">
  <unfence>
    <device action="enable" name="myfence" port="1"/>
  </unfence>
  <fence>
    <method name="Method">
      <device name="myfence" port="1"/>
    </method>
  </fence>
</clusternode>
<fencedevices>
  <fencedevice agent="fence_brocade" ipaddr="ipaddr" login="root" name="myfence" passwd="password"/>
</fencedevices>

3. Rename the "myfence" device to "newfence". Cluster.conf snippet will look like this (notice the invalid reference in unfence section):
<clusternode name="z2" nodeid="1">
  <unfence>
    <device action="enable" name="myfence" port="1"/>
  </unfence>
  <fence>
    <method name="Method">
      <device name="newfence" port="1"/>
    </method>
  </fence>
</clusternode>
<fencedevices>
  <fencedevice agent="fence_brocade" ipaddr="ipaddr" login="root" name="newfence" passwd="password"/>
</fencedevices>



Actual results:
Unfence reference is not updated.


Expected results:
Unfence reference is updated.

Comment 1 Ryan McCabe 2012-12-04 01:56:43 UTC
Fixed in upstream commit

commit 9374af9e6e5f682d3d0cf2844608f7a5db105fa7
Author: Ryan McCabe <rmccabe@redhat.com>
Date:   Mon Dec 3 20:54:52 2012 -0500

    luci: Update unfence when renaming fence devices
    
    If a fence device is renamed, update any unfence instances
    that refer to its old name.
    
    Resolves: rhbz#882995
    
    Signed-off-by: Ryan McCabe <rmccabe@redhat.com>

Comment 6 errata-xmlrpc 2013-02-21 08:23:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0309.html


Note You need to log in before you can comment on or make changes to this bug.