Bug 88306 - Java threads won't run in applets with custom kernel
Java threads won't run in applets with custom kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 15:12 EDT by Rodary Jacques
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 08:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodary Jacques 2003-04-08 15:12:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
   With a custom kernel 2.4.20 which I recompiled with gcc-3.2.2-5 from
RH9, applets I wrote (and recompiled with javac from Sun JDK1.4.1_02)
won't  run properly. It's not a  NPTL thread isuue, as they do run
properly with the 2.4.20-8smp kernel installed with rh9. They also ran with rh7.3


Version-Release number of selected component (if applicable):
kernel-2.4.20

How reproducible:
Always

Steps to Reproduce:
1.upgrade from redhat 7.3 to redhat 9
2.boot with custom kernel 2.4.20smp-perso
3.launch applet with threads (with mozilla, appletviewer or binfmt-misc).
    

Actual Results:  My applet uses a volatile Thread supposed to draw a blinking
image,actally a text. The text doesn't show with my custom kernel, as it did
before, and still does with kernel-2.4.20-8smp coming with redhat9

Expected Results:  Same as before or with your kernel

Additional info:
Comment 1 Arjan van de Ven 2003-04-08 15:25:38 EDT
so you use an app that we don't ship and find it doesn't get along with a kernel
we don't ship. Could you explain how this is a bug for me ??? ;)
Comment 2 Rodary Jacques 2003-04-08 17:48:00 EDT
It's definitely *not* a bug for you. But I was used, since 1998, and RedHat 5.0,
to helpful corporates at redhat, even when I didn't pay anything (nevertheless I
paid for RH 5.0,5.1,6.0,6.1,6.2, and rhn 15 days ago). I first asked on redhat's
newsgroups, and got no answers. Even if you don't feel concerned about it all,
just forward yo your boss(es). Thanks 
Comment 3 Mike A. Harris 2003-04-09 03:44:58 EDT
Sounds like a problem that should be reported to Sun, so they can fix
their Java.  Definitely not a Red Hat bug if you're using a kernel we
don't ship with software we don't ship.
Comment 4 Rodary Jacques 2003-04-26 09:46:52 EDT
GuruLabs gave me the answer: Java Plugin from Sun does'nt work with mozilla 1.3.
You have to switch back to mozilla 1.2.1 (and so you can use galeon!), or switch
to Blackdown java. I feel you could have tried to find this answer for me.
Comment 5 Arjan van de Ven 2003-04-26 09:50:38 EDT
Bugzilla is not a support mechanism, see http://www.redhat.com/support for that.
I'm a kernel engineer, and I'm more than happy to receive defect reports about
the kernel, but I don't know nor work on mozilla, which you didn't even mention
you had changed to a non-RHL version.
Comment 6 Mike A. Harris 2003-04-26 23:09:58 EDT
Indeed, I must second Arjan here.  Many people file "help" requests in bugzilla,
perhaps because they don't know where else to turn, but bugzilla very much
is not a technical support forum of any kind.

While it is true that any of us could have dropped what we are doing as
work tasks and ran around the internet randomly looking for a solution to your
problem, that is not what we are paid to do.  We are paid as developers to
fix bugs in the individual software components we maintain, and to do development
and various other things.  Not for technical support however.

If anyone requires any form of technical support, Red Hat provides both
mailing lists for community based tech support forums, and also corporate
tech support contracts.
Comment 7 Rodary Jacques 2003-04-28 08:40:19 EDT
 Sorry. I did'nt even think mozilla-1.3 was the cause, as it worked before with
rh7.3, and with RHL kernel 2.4.20-9smp. I was only hoping you could tell me
which related kernel config option was set inyour kernel.   

Note You need to log in before you can comment on or make changes to this bug.