Bug 883086 - RFE: Media check should not be the default
RFE: Media check should not be the default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-03 13:14 EST by Michael Cronenworth
Modified: 2013-02-04 13:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 13:29:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2012-12-03 13:14:06 EST
Description of problem: The installer images have the media check as the default boot item. This causes a long delay due to bug 874486. Even with that bug fixed, media checking has always been an optional step.

Since the text of the boot menu is hard to understand what is selected, I did not know the second item (media check) was selected. I let it default boot and met the long delay and thought the system locked up.


Version-Release number of selected component (if applicable): F18 Beta
Comment 1 Andre Robatino 2012-12-03 13:35:01 EST
That bug only prevents the mediacheck progress indicator from being displayed. The delay is the same, but the consequences are a lot worse since most users don't know what's going on and some may give up rather than wait for it to complete. If it was working, they'd know what was happening and roughly how long it would take, and could get a cup of coffee rather than wasting their time staring at the screen. Therefore, I think that bug should be fixed before deciding whether to change the default status. (Especially since most people are far too careless about checking their media, and the amount of wasted time for a failed install/upgrade far exceeds that for a mediacheck.)

Also, default and optional are not opposites. It's still optional, you just disable it by choosing the non-mediacheck boot entry. Personally I'd like to have the old interactive method where it asks whether to do the mediacheck (which would be simpler now since split media are gone and it doesn't have to walk you through swapping discs), but that probably won't happen.
Comment 2 Andre Robatino 2012-12-03 16:06:46 EST
Actually, I see from https://bugzilla.redhat.com/show_bug.cgi?id=874486#c6 that the intent is that you can hit ESC to abort the mediacheck (and command-line checkisomd5 says "Press [Esc] to abort check." so presumably that would be visible). So there are two ways involving one keystroke to avoid the mediacheck - either by boot menu, or hitting ESC if mediacheck was chosen by mistake (once bug 874486 is fixed).
Comment 3 Fedora Admin XMLRPC Client 2013-02-04 10:04:46 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Brian Lane 2013-02-04 13:29:35 EST
lorax isn't going to decide the policy here. Fedora wants to have the mediacheck the default.

Note You need to log in before you can comment on or make changes to this bug.