Bug 88313 - man does'nt display accented characters
Summary: man does'nt display accented characters
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 20:27 UTC by Jacques Rodary
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-02 19:03:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jacques Rodary 2003-04-08 20:27:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
man  does'nt display accented characters of french manpages. Is there still
something like MANCHARSET or LESSCHARSET to set? If ye, what are the admissibles
values?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.upgrade from rh7.3 to rh9
2.run man -a <manpage>
3.
    

Actual Results:  � � � etc... show as ?.

Expected Results:  correct display as before

Additional info:

Comment 1 Jacques Rodary 2003-04-08 21:58:14 UTC
Reading my mail, I feel bugzilla  has the same problem; LoL -:)

Comment 2 Jacques Rodary 2003-04-26 13:51:52 UTC
Is there anybody out there (Pink Floyd, the Wall)?

Comment 3 Eido Inoue 2003-04-28 16:44:46 UTC
what locale are you using? (type "locale" at the command line)

Comment 4 Jacques Rodary 2003-05-07 00:27:01 UTC
LANG=fr_FR@euro
LC_CTYPE="fr_FR@euro"
LC_NUMERIC="fr_FR@euro"
LC_TIME="fr_FR@euro"
LC_COLLATE="fr_FR@euro"
LC_MONETARY="fr_FR@euro"
LC_MESSAGES="fr_FR@euro"
LC_PAPER="fr_FR@euro"
LC_NAME="fr_FR@euro"
LC_ADDRESS="fr_FR@euro"
LC_TELEPHONE="fr_FR@euro"
LC_MEASUREMENT="fr_FR@euro"
LC_IDENTIFICATION="fr_FR@euro"
LC_ALL=


Comment 5 Jacques Rodary 2003-06-10 21:06:27 UTC
Still hoping for an answer. Thanks

Comment 6 Eido Inoue 2003-06-10 21:20:12 UTC
Try

LANG=fr_FR.UTF-8@euro man ls

not just 

LANG=fr_FR@euro


Comment 7 Jacques Rodary 2003-06-11 13:52:07 UTC
I tried LANG=fr_FR.UTF-8@euro: it qgaves things like répertoires instead of
répertoire. But LANG=fr_FR works, I am sure it didn't with RH7.3), and I still
have the euro sign â¬. I don't understand, but thanks anyway.

Comment 8 Eido Inoue 2003-06-11 16:49:16 UTC
Is your terminal set to display UTF-8? If it isn't you're receive gargage.

The reason fr_FR works and fr_FR@euro doesn't is because they use different
character sets: fr_FR uses iso-8859-1 (aka Latin-1) and fr_FR@euro uses
iso-8859-15 (aka Latin-9 or Latin-0)

The default character encoding for Red Hat Linux 8 and beyond (for European
language-- other languages (esp CJK) will be migrated to UTF-8 in later
versions) is UTF-8, which is different from 7.3.

Comment 9 Jacques Rodary 2003-06-18 23:09:49 UTC
I have been trying (very hard) to tell you that UTF8 does'nt work at all with
any west european locale (and possibly others). Please try them. For your
information,  my last comment said ini works, but I have to use kde konsole (in
gnome !!!).Gnome terminal won't accept  fr_FR locale. 

Comment 10 Jungshik Shin 2003-09-01 07:37:57 UTC
> Is your terminal set to display UTF-8? 
> If it isn't you're receive gargage.

  reporter, you didn't answer this question. However, I confirmed 
that 'man' doesn't work the way it should. There are two problems. 
One of them is not the fault of man but that of less (see bug 88868).
To see that, you can do the following:

  1. $ env LC_ALL=fr_FR.UTF-8 xterm &
  2. In a new xterm window, 

     $ env LANG=fr_FR.UTF-8 man man -P more

     You'll see that letters with diacritic marks are
     rendered correctly

  3. In the same xterm,
      
      $ env LANG=fr_FR.UTF-8 man man 
   
     would not work.

  Because the default pager for 'man' is 'less -isr', 
  this is a clear indication that 'less' is to blame.

Now, what's the problem of 'man' I wrote about above?
That is, it's not compliant to the POSIX-specified locale 
resolution-order. When LC_ALL is specified, it should have
the highest priority, but it still selects the man page based 
on LANG. I'll file it as a separate bug.



  


Comment 11 Jungshik Shin 2003-09-01 16:05:32 UTC
sorry. the first part of my comment #10 is wrong. I didn't relaize that
JLESSCHARSET was set to 'ko'. With that unset, 

LANG=fr_FR.UTF-8 /usr/bin/man man

works fine in a UTF-8 terminal.

So, this bug as reported should be closed.


On the other hand, I have a trouble with fr_FR (fr_FR@euro) in a ISO-8859-1 or
ISO-8859-15 terminal. Letters with diacritic marks come up as question
marks.Using '-P more' didn't change this.

When I use fr_FR.ISO-8859-1 or fr_FR.ISO-8859-15, they come up correctly. 

Because '-P more' change didn't make any difference, I suspect that either man
or groff is to blame for not using nl_langinfo(CODESET) but relying on parsing
the value of LANG to determine the codeset.


Comment 12 Eido Inoue 2003-09-02 19:03:59 UTC
as per comment #11, closing


Note You need to log in before you can comment on or make changes to this bug.