Bug 883191 - "This URL refers to a mirror" should read "This URL refers to a mirror list" (Installation Location spoke)
"This URL refers to a mirror" should read "This URL refers to a mirror list" ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-03 19:46 EST by Adam Williamson
Modified: 2012-12-06 02:29 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.35-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 02:29:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-12-03 19:46:36 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=868558#c31 and down - the basic bug there is now fixed, you can use a mirror list URL, but the checkbox that was added is labelled wrongly: it reads 'This URL refers to a mirror', not 'This URL refers to a mirror list' as it should. Not only will people are entering mirror list URLs not check the box (as they should), but possibly people who are entering direct mirror URLs will check the box (as they shouldn't) - this bad label could break both cases.

Proposing as a blocker - it's only a UI bug, but it's a significant one, as it can cause everyone who enters a URL to do the wrong thing.
Comment 1 Fedora Update System 2012-12-04 19:57:14 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
Comment 2 Robyn Bergeron 2012-12-05 03:35:01 EST
It's unclear to me from reading this ticket and 868558 as to whether or not things are labelled backwards (and thus, upon entering a mirror URL, clicking the button to indicate that it is a mirror, when the button is supposed to only be clicked for mirror lists), if the button should be clicked regardless of it being a mirrorlist or direct mirror URL (which I can see happening either way - clicking yes in both cases, or saying that a mirrorlist is not a mirror in not clicking).... or if it is a change from what was asked at this stage in F17 that is causing confusion.  (Since we previously had "this URL refers to a mirrorlist")

If it really and truly means "is this a mirror", and not mirror list, then that might be worthwhile documenting as a change from previously expected behavior.

If it is really being done it to differentiate between mirrors and mirror lists, and that alone, then it seems more logical (to me, and here is your grain of salt) to isolate the item that cannot possibly construed as one subset of the other. I can see people entering a mirror list URL and clicking the box, thinking, "it's sort of a glorified supermirror, right?" - but entering a direct mirror URL is much less likely to be confused with the more specific "This URL refers to a mirrorlist."

If people consider "my own personal repo" to be "a mirror" and we only want direct mirror URLs to get clicked then that brings in an extra universe of fun in wording it as "mirror" vs. "mirrorlist" in that way. I'm not sure that that's common thought though.  

But like I said - I'm unclear from bz comments as to if the buttons are actually implementing things incorrectly in certain cases, or if it's just confusing and likely to lead to disaster.  (And if that level of disaster continues to be as adamw described in comment 31 of 868558.)
Comment 3 Adam Williamson 2012-12-05 04:08:44 EST
The box means what it meant before. You're meant to check it if the URL is a 'mirror list', not if the URL is a 'mirror'. It is currently directing you to do exactly the opposite of what you actually ought to do. If the URL you are entering is a direct mirror URL you should *not* check the box. If the URL you are entering is a mirror list URL you *should* check the box. The text 'This URL refers to a mirror' gives you precisely the wrong idea.
Comment 4 Robyn Bergeron 2012-12-05 05:04:14 EST
+1 blocker - "The installer must be able to use all supported local and remote package source options" - it is not usable if requesting the wrong type of input.
Comment 5 Kamil Páral 2012-12-05 05:22:56 EST
Fixed in anaconda 18.35.
Comment 6 Kamil Páral 2012-12-05 05:23:53 EST
(I mean I verified it in anaconda 18.35 and it looks OK now)
Comment 7 Fedora Update System 2012-12-06 02:29:35 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.