Bug 883195 - [custom part usability] Make it clearer that actions on the custom part screen do not take effect until 'Begin Installation'
[custom part usability] Make it clearer that actions on the custom part scree...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-03 20:06 EST by Adam Williamson
Modified: 2013-04-08 23:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-19.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-08 23:39:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-12-03 20:06:05 EST
Another common theme in feedback on newUI custom part has been that people are 'scared' of experimenting in it. A recent thread in particular:

http://forums.fedoraforum.org/showthread.php?t=286370

points out that the presence of an 'Apply Changes' button can actually act as a warning flag - if I click that, will it eat my partitions? What it means is 'Apply changes to the display of the proposed layout', but that's not obvious at all.

Again a common theme: I'm not sure of the best way to fix this. But can we somehow clue in the user that nothing at all irreversible happens until they click 'Begin Installation' on the hub?
Comment 1 Adam Williamson 2012-12-04 02:32:58 EST
http://forums.fedoraforum.org/showpost.php?p=1617950&postcount=7 has an interesting summary - we could do this on the hub, not any spoke, because it actually applies everywhere. Just a note on the hub that no changes will actually be committed until the user hits Begin Installation.
Comment 2 Adam Williamson 2013-01-24 11:54:04 EST
For the record - as I filed https://bugzilla.redhat.com/show_bug.cgi?id=903498 last night, which is somewhat similar to this - this fix adds the following label to the Begin Installation button:

"We won't touch your disks until you hit this button."

It's clearly an improvement, but it may still be worth doing it at the disk shopping cart and tweaking the language in the storage config screens in a few places too.
Comment 3 Adam Williamson 2013-01-30 17:30:21 EST
let's mark this as 'closed' for now as the fix is already in the latest anaconda build in rawhide (verified). I still think the 'Apply Changes' button in custom part is kinda problematic UI, but we can come to that later.
Comment 4 Máirín Duffy 2013-02-12 15:00:07 EST
I'm re-opening this bug, because the text that would help resolve it is on the disk selection screen, not on the custom part screen.

Stephanie and I reviewed this bug today and came up with the following plan of attack:

1) We're going to change the label of the 'Apply Changes' button. We have two ideas, either change it to 'Save Changes' ('save' is a little safer of a term than 'apply') or 'Update Settings' (here the verb is settings, so it's clear it won't touch your disk.

We aren't sure which label will be less intimidating for users. Stephanie is going to mock up both and we'll do some quick paper prototype testing of paper printouts of the two mockups and see what potential users think about the text.

2) We're going to add a message to the custom partitioning screen to let people know the changes won't apply until they hit 'begin installation' on the first hub. Stephanie is going to mock this up in her mockup as well, and refer to the mockup in bug 903498 to make sure the text she comes up with for custom partitioning is a reasonable match to the wording in that mockup (for disk selection.)
Comment 5 Adam Williamson 2013-02-14 21:24:07 EST
Great. One more thought: it might be worth talking to devs about whether it'd be feasible to just do away with the need for the button entirely. It seems like a bit of a hack for it to exist in the first place. With smart enough coding, couldn't we make the screen use the 'instant apply' principle and get rid of the button? It would just have to be smart about when it applied changes. Might not be possible, but worth thinking about.
Comment 6 Máirín Duffy 2013-02-16 00:09:10 EST
The original design was that we had no button at all, there was some technical reason it had to be added back (dlehman would probably remember, I don't.)
Comment 8 Chris Lumens 2013-03-28 12:02:22 EDT
Whoops, POST was the right choice for the moment.
Comment 9 Fedora Update System 2013-04-02 20:08:15 EDT
anaconda-19.15-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.15-1.fc19
Comment 10 Fedora Update System 2013-04-03 12:09:08 EDT
Package anaconda-19.15-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.15-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4754/anaconda-19.15-1.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-04-04 20:51:35 EDT
anaconda-19.16-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.16-2.fc19
Comment 12 Fedora Update System 2013-04-08 23:39:29 EDT
anaconda-19.16-2.fc19, python-meh-0.22-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.