Bug 883355 - VDSM yum installation fails when selinux is disabled: RuntimeError: Cannot allocate memory
VDSM yum installation fails when selinux is disabled: RuntimeError: Cannot al...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2012-12-04 06:55 EST by Ohad Basan
Modified: 2014-10-30 18:34 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 19:30:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2012-12-04 06:55:06 EST
Description of problem:
installation of vdsm fails when installation on a fedora18 beta machine where selinux is disbled

Version-Release number of selected component (if applicable):
3.1

How reproducible:
always

Steps to Reproduce:
1.install fedora18 beta 
2.setup up the ovirt nightly repository
3.run "yum install vdsm"
  
Actual results:
installation quits with the following error
Total download size: 616 k
Installed size: 2.4 M
Is this ok [y/N]: y
Downloading Packages:
vdsm-4.10.2-0.67.git8ca42e9.fc18.x86_64.rpm                                                                                                                            | 616 kB  00:00:04     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : vdsm-4.10.2-0.67.git8ca42e9.fc18.x86_64                                                                                                                                    1/1 
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 143, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 125, in main
    load_modules()
  File "/usr/bin/vdsm-tool", line 74, in load_modules
    module = imp.load_module(mod_name, mod_fobj, mod_absp, mod_desc)
  File "/usr/lib64/python2.7/site-packages/vdsm/tool/seboolsetup.py", line 21, in <module>
    import seobject
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 27, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 43, in <module>
    policy(policy_file)
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 40, in policy
    _policy.policy(policy_file)
RuntimeError: Cannot allocate memory
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 143, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 125, in main
    load_modules()
  File "/usr/bin/vdsm-tool", line 74, in load_modules
    module = imp.load_module(mod_name, mod_fobj, mod_absp, mod_desc)
  File "/usr/lib64/python2.7/site-packages/vdsm/tool/seboolsetup.py", line 21, in <module>
    import seobject
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 27, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 43, in <module>
    policy(policy_file)
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 40, in policy
    _policy.policy(policy_file)
RuntimeError: Cannot allocate memory



Expected results:
packages installed successfully.

Additional info:
Comment 1 Federico Simoncelli 2012-12-04 11:38:42 EST
This looks like a policycoreutils-python issue. What's the policycoreutils-python version that you're using? Can you try to update the package? Thanks.
Comment 2 Ohad Basan 2012-12-04 11:43:17 EST
the version is policycoreutils-python-2.1.13-37.fc18.x86_64 and currently it is the latest version in the repo and can't be upgraded.
Comment 3 Federico Simoncelli 2012-12-05 06:47:47 EST
This is a policycoreutils-2.1.13-37.fc18.x86_64 issue:

# python
Python 2.7.3 (default, Aug  9 2012, 17:23:57) 
[GCC 4.7.1 20120720 (Red Hat 4.7.1-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import seobject
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 27, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 31, in <module>
    policy(policy_file)
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 28, in policy
    _policy.policy(policy_file)
RuntimeError: Cannot allocate memory

# semanage
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 25, in <module>
    import seobject
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 27, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 43, in <module>
    policy(policy_file)
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 40, in policy
    _policy.policy(policy_file)
RuntimeError: Cannot allocate memory
Comment 4 Daniel Walsh 2012-12-06 09:16:56 EST
Fixed in policycoreutils-2.1.12-43
Comment 5 Fedora Update System 2012-12-10 09:12:01 EST
policycoreutils-2.1.13-44.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.13-44.fc18
Comment 6 Fedora Update System 2012-12-10 16:14:53 EST
Package policycoreutils-2.1.13-44.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.13-44.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20070/policycoreutils-2.1.13-44.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-11 19:30:51 EST
policycoreutils-2.1.13-44.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.