Bug 883357 - Unable to start/restart RHQ server via "Operation-->Schedules"
Unable to start/restart RHQ server via "Operation-->Schedules"
Status: CLOSED DUPLICATE of bug 1032039
Product: RHQ Project
Classification: Other
Component: Operations (Show other bugs)
4.5
All Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-04 06:58 EST by Jeeva Kandasamy
Modified: 2014-11-19 07:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-19 07:53:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeeva Kandasamy 2012-12-04 06:58:16 EST
Description of problem:
Unable to start/restart RHQ Server via "Schedules-->Operations". Able to stop RHQ server successfully.

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version: 3.1.2.ER2
Build Number: 504cef5:b78316e
GWT Version: 2.5.0
SmartGWT Version: 3.0

How reproducible:
100%

Steps to Reproduce:
1. Install 2 JON servers and 2 agents. (Host-A and Host-B)
2. Register Host-A agent on Host-B server and register Host-B agent on Host-A server.
3. Now we can control Host-A resources from Host-B server and vice-versa
4. Do restart/start Host-A JON server from Host-B server GUI. Location: "Inventory-->Servers-->RHQ Server-->Operation--> Schedules-->New-->Operation-->Restart/Start".
5. After initiated this operation JON server is not starting, can see some process as follows,
-------------------------------------------
hudson   30345  2932  0 18:10 ?        00:00:00 /bin/sh /home/hudson/jon-server-3.1.2.ER2/jbossas/bin/run.sh -c default -b 0.0.0.0
hudson   30369 30345 42 18:10 ?        00:00:23 /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/bin/java -Dprogram.name=run.sh -Xms128M -Xmx512M -XX:MaxPermSize=256M -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Djava.endorsed.dirs=/home/hudson/jon-server-3.1.2.ER2/jbossas/lib/endorsed -classpath /home/hudson/jon-server-3.1.2.ER2/jbossas/bin/run.jar org.jboss.Main -c default -b 0.0.0.0
-------------------------------------------
  
Actual results:
Unable to start/restart the JON server.

Expected results:
Should able to restart/start JON server.
Comment 1 Libor Zoubek 2014-11-19 07:53:37 EST

*** This bug has been marked as a duplicate of bug 1032039 ***

Note You need to log in before you can comment on or make changes to this bug.