Bug 883365 - [engine] [upgrade] Unable to perform operations as user on existing VM after upgrade from RHEV 3.0 to 3.1
[engine] [upgrade] Unable to perform operations as user on existing VM after ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
All Linux
urgent Severity high
: ---
: 3.2.0
Assigned To: Oved Ourfali
Pavel Stehlik
virt
: ZStream
Depends On:
Blocks: 888317 915537
  Show dependency treegraph
 
Reported: 2012-12-04 07:19 EST by Gadi Ickowicz
Modified: 2014-08-21 21:41 EDT (History)
12 users (show)

See Also:
Fixed In Version: sf1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 888317 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gadi Ickowicz 2012-12-04 07:19:59 EST
Description of problem:
After upgrading from 3.0 to 3.1 and entering the user-portal attempting to perform operations on an existing VM that was already configured with user as PowerUser role fails with "User is not authorized to perform this action".

How reproducible:
?

Steps to Reproduce:
1. Create a VM with a disk and assign a user to it as PowerUser role (make sure user does not have any other permissions) on 3.0
2. Enter user portal with user and run the VM (this works)
3. Upgrade to 3.1
4. Login to user portal and try to run VM or perform any other operation on it - fails due to permission error as diskCreator role was not added to the user
  
Actual results:
Unable to perform operations on VM with disk after upgrade without assigning diskCreator permissions manually to user

Expected results:
Users that were able to perform operations before upgrade should be able to perform the same operations after the upgrade without further permissions
Comment 8 Oved Ourfali 2012-12-18 02:59:08 EST
Fix posted:
http://gerrit.ovirt.org/#/c/10183/
Comment 9 Oved Ourfali 2012-12-18 03:03:39 EST
Commit: 1ebc198ab5d33105c97caa6eb50c7f1d8a3ef1b8

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=1ebc198ab5d33105c97caa6eb50c7f1d8a3ef1b8
Comment 12 Itamar Heim 2013-06-11 04:59:39 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:59:39 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 04:59:39 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 05:01:12 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 05:30:42 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.