Bug 883461 - FC18: Kickstart installation is not possible.
FC18: Kickstart installation is not possible.
Status: CLOSED DUPLICATE of bug 888841
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
18
s390x All
unspecified Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-04 11:32 EST by IBM Bug Proxy
Modified: 2013-08-22 14:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 14:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot for OBSERVATION 1, parse error in ks file (198.02 KB, image/png)
2012-12-04 11:33 EST, IBM Bug Proxy
no flags Details
Screen shot for OBSERVATION 2, no IP address found (110.97 KB, image/png)
2012-12-04 11:33 EST, IBM Bug Proxy
no flags Details
The kickstart file (942 bytes, text/plain)
2012-12-04 11:33 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 86885 None None None Never

  None (edit)
Description IBM Bug Proxy 2012-12-04 11:32:43 EST
Once the manual installation is done a kickstart file "anaconda-ks.cfg" gets stored in the /root directory. If we take this kickstart file and point to it in the ".parms" file, and restart the manual installation, there are certain errors thrown by the installer. Please refer to the screen-shots.

These are the following two errors that we find:

1. parse-kickstart ERROR: The following problem occurred on line 23 of the kickstart file:
unknown command: --type=lvm
2. No IP addresses found, cannot continue installation
Comment 1 IBM Bug Proxy 2012-12-04 11:33:06 EST
Created attachment 657633 [details]
Screen shot for OBSERVATION 1, parse error in ks file
Comment 2 IBM Bug Proxy 2012-12-04 11:33:27 EST
Created attachment 657634 [details]
Screen shot for OBSERVATION 2, no IP address found
Comment 3 IBM Bug Proxy 2012-12-04 11:33:46 EST
Created attachment 657635 [details]
The kickstart file
Comment 4 IBM Bug Proxy 2012-12-05 04:31:08 EST
------- Comment From manibajp@in.ibm.com 2012-12-05 09:27 EDT-------
(In reply to comment #10)
> Could you also include what release of Fedora 18 you're installing?

I was trying this on the release:

http://s390.koji.fedoraproject.org/tree/test/20121113/s390x/os/

and the same issue can also be observed on the beta release i.e.:

http://s390.koji.fedoraproject.org/tree/test/20121128/s390x/os/
Comment 5 Chris Lumens 2012-12-05 10:18:54 EST
Please file a second bug for the second issue.  The first appears to be a pykickstart problem, so I am going to move it to that component.
Comment 6 Chris Lumens 2012-12-07 15:21:02 EST
I am unable to reproduce the issue with the bad line in the kickstart file.  Can you think of any choices you made during installation that could have affected this?  Also, can you please try a post-beta tree and see if that fixes this for you?  Thanks.
Comment 7 Jan Stodola 2013-01-25 07:09:24 EST
The first issue seems to be the same as bug 888841.
Comment 8 IBM Bug Proxy 2013-02-07 04:21:28 EST
------- Comment From onmahaja@in.ibm.com 2013-02-07 09:10 EDT-------
RH, Any progress on this issue ?
Comment 9 IBM Bug Proxy 2013-08-05 13:55:52 EDT
(Note: fix for the repeated needinfo flags during mirroring was implemented earlier this year; attempt to clear the flags to validate.)
Comment 10 Chris Lumens 2013-08-22 14:56:23 EDT
If you can reliably reproduce the second problem, please open a new bug against anaconda containing /tmp/anaconda.log and your kickstart file.  Thanks.

*** This bug has been marked as a duplicate of bug 888841 ***

Note You need to log in before you can comment on or make changes to this bug.