Bug 883555 - Anaconda is missing croatian keyboard layout
Anaconda is missing croatian keyboard layout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker https://f...
: CommonBugs, Reopened
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-12-04 16:08 EST by Vedran Miletić
Modified: 2013-05-30 01:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-19.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 22:09:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vedran Miletić 2012-12-04 16:08:04 EST
Anaconda provides Serbo-Croatian (US) keyboard, but Croatian keyboard (setxkbmap hr) and it's variants are missing.
Comment 1 Chris Lumens 2012-12-05 10:12:25 EST
anaconda doesn't have its own list of keyboard layouts.  We get it from querying the system for supported layouts.
Comment 2 Vedran Miletić 2012-12-22 14:04:52 EST
I just tested 18-TC3 and this issue still happens; however, Croatian layout is present for selection under GNOME 3's Region & Language after installation.
Comment 3 Vedran Miletić 2012-12-30 07:29:37 EST
Adding CC's in case maintainer in Bugzilla is not set correctly.
Comment 4 Vedran Miletić 2013-01-02 12:34:41 EST
Proposing as F18Blocker.
Comment 5 Adam Williamson 2013-01-02 14:36:38 EST
Discussed at 2013-01-02 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2013-01-02/f18final-blocker-review-8.2013-01-02-17.03.log.txt . Rejected as a blocker: this is obviously bad for Croatian users, but we just felt the number of people affected is low enough that, if this were the last bug, we would not delay release a week to fix it (the 'last bug' smell test). Accepted as NTH, it would be good to figure out what's going on here and fix it so Croatian users can use their correct layout during install.
Comment 6 Ray Strode [halfline] 2013-01-02 14:43:21 EST
looking in /usr/share/systemd/kbd-model-map the console keymap associated with the hr x layout is "croat"

The console keymaps and x layouts are different.  There is an effort to consolidate them, but there are some perl dependency complicates.  See bug 680990 and bug 837292
Comment 7 Ray Strode [halfline] 2013-01-02 14:44:25 EST
(you may be used to setxkbmap hr working in other distros that have already consolidated x layouts and console keymaps)
Comment 8 Adam Williamson 2013-01-03 22:46:16 EST
How does that make this notabug? I don't see the relevance. There is an xkb layout for Croatian. anaconda is supposed to offer all available xkb layouts. It doesn't care about kbd layouts.
Comment 9 Adam Williamson 2013-01-03 22:49:33 EST
Note anaconda has no problem offering all sorts of other layouts whose kbd equivalent has a different name, or for which there is no kbd equivalent at all. I think you're misunderstanding how newUI does keyboard layouts. http://vpodzime.fedorapeople.org/layouts_list.py and http://fedoraproject.org/wiki/Anaconda/Kickstart#keyboard may help, from the big brouhaha bug (https://bugzilla.redhat.com/show_bug.cgi?id=889562 ).
Comment 10 Valent Turkovic 2013-01-06 12:16:10 EST
This is much more that a software bug.

This could be a really serious bug because of it's political weight. Currently there is only Croatian keyboard listed with English keys but it says that this is "Serbo-Croatian" keyboard. 

Maybe you don't understand the weight of this but Croatia fought war for independence 20 years ago so that it could have it culture and language as it's own and not part of some be forceably par of some other culture (Serbo-Croatian led Yugoslavia).

Thanks for your understanding.
Comment 11 Ray Strode [halfline] 2013-01-06 12:54:09 EST
(In reply to comment #8)
> How does that make this notabug? I don't see the relevance.

My mistake. When i read "setxkbmap hr" my brain interpreted it as "loadkeys hr"
Comment 12 Adam Williamson 2013-01-06 13:52:38 EST
valent: the 'Serbo-Croatian' layout is part of upstream xkb. See /usr/share/X11/xkb/symbols/us (it's a variant of the U.S. layout):

// Serbian charecters added as third level symbols to US keyboard layout.

partial alphanumeric_keys
xkb_symbols "hbs" {

  name[Group1]= "Serbo-Croatian (US)";

  include "us"

It is present in the upstream copy:

http://cgit.freedesktop.org/xkeyboard-config/tree/symbols/us

I don't think we're going to go around patching upstream xkb on a political basis. If you want this changed, file it at:

https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config
Comment 13 Mihael 2013-01-24 03:32:58 EST
Adam: This is a matter of the common sense. The "Serbo-Croatian" language does not exist. You are offering non existing language to the users which. This is the same thing as removing the English or any other official language from the list. 

Ubuntu on the orher hand, offers Croatian layout and keyboard from the start of the installation.
Comment 14 Valent Turkovic 2013-01-24 03:49:26 EST
Thank you Adam and Ray for tracking down this bug. I posted it to upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=59789
Comment 15 Adam Williamson 2013-01-24 03:52:24 EST
Mihael: the dialog in question is for *keyboard layouts*, not languages. Serbo-Croatian is a keyboard variant provided by Xkb. It really exists. It is in the file /usr/share/X11/xkb/symbols/us , as shown in comment #12. That comes from xkb. If you think it shouldn't be in xkb, go tell xkb about it. It is not Anaconda's problem. Anaconda's problem is that the Croatian layout that exists in Xkb is *not* being shown. That is what we want to focus on here. Please stop complaining about irrelevant issues that are not Fedora's problem.
Comment 16 Adam Williamson 2013-01-24 03:55:00 EST
Valent: I'm afraid you rather misunderstood my comments. Xkb does provide a 'Croatian' layout. GNOME's keyboard config tool finds it just fine. anaconda, for some reason, does not: that is the bug here. It is a downstream anaconda bug, not an upstream Xkb bug.

I only mentioned upstream in the context of people who think the 'Serbo-Croatian' layout is bogus. I am pointing out that that layout is a part of upstream Xkb, it is not Fedora's job to decide it shouldn't exist. It looks to be a variant of the U.S. layout intended for allowing one to enter characters that commonly appear in Serbian and Croatian.
Comment 17 Mihael 2013-01-24 06:25:19 EST
Adam: Given the limited time and knowledge about xkb I will do my best to understand the issue. I apologize for misinterpretation in my previous post.

I don't care what hapens to the Serbo-Croatian layout. Personally, I think that it shound be deleted, but this is not my point.

Concerning the keyboard layouts (comment #12), there is this layout upstream:

http://cgit.freedesktop.org/xkeyboard-config/tree/symbols/hr

and I want it to be available for choosing durring the installation of Fedora 18. This is Anaconda's problem, please fix it.
Comment 18 Vratislav Podzimek 2013-05-16 06:50:47 EDT
Patch for the anaconda to provide more layouts sent to anaconda-patches.
Comment 19 Fedora Update System 2013-05-21 19:34:58 EDT
anaconda-19.29-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.29-1.fc19
Comment 20 Fedora Update System 2013-05-22 18:36:19 EDT
Package anaconda-19.29-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.29-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8821/anaconda-19.29-1.fc19
then log in and leave karma (feedback).
Comment 21 Adam Williamson 2013-05-29 22:09:25 EDT
Croatian is indeed available in 19 Beta. Closing.

Note You need to log in before you can comment on or make changes to this bug.