Bug 88356 - rhn-applet never gets past checking (green icon) in kde
rhn-applet never gets past checking (green icon) in kde
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 07:48 EDT by Jason Corley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 08:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Corley 2003-04-09 07:48:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a)
Gecko/20030401

Description of problem:
Under kde I have two machines that the rhn-applet in the kpanel never gets past
the green icon.  I've removed the icon, logged out, logged back in and re-added
it.  It just doesn't seem to work, no matter how long I give it (days on end). 
I have an enterprise RHN license for both machines that I'm attempting this
with.  Usernames are togethersoft and corleyja.

Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-0.9.0.1

How reproducible:
Always

Steps to Reproduce:
1. Add rhn-applet to kde panel (or use the one that is there to begin with)
2. Wait for something besides green icon.
3. Learn to love green icon.  Or remove it.
    

Expected Results:  rhn-applet should display up2date status.

Additional info:
Comment 1 Daniel Veillard 2003-04-09 08:35:52 EDT
I can't reproduce this. My KDE installation is pristine installed with
Red Hat 9, when loggin in, the applet is there, it starts blue until the
first check-in to the RHN service, it then turned green when I asked
to check for updates from the menu, it then turned red with the flashing
exclamation point indicating that upgrades were needed. I launched up2date
to grab the updates and once installed, the applet icon turned back to blue,
all as expected.
  Sorry I can't reproduce this with the "Steps to Reproduce:" indicated.
Maybe you set up a proxy and this one is misconfigured, that would be the
only reason I can think of why the icon would stay green for a long time.

Daniel
Comment 2 Jason Corley 2003-04-09 09:18:46 EDT
Hmmm...  I removed the applet from the panel a number of times and re-added it
using the add panel menu.  I assume the correct one is Panel Menu -> Add ->
Application Button -> System Tools -> Red Hat Network Alert Icon?  Also running
rhn-applet-gui from a command line doesn't do anything, but running
rhn-applet-tui outputs:

[jasonc@jcorley jasonc]$ rhn-applet-tui
Ignoring
No package updates are needed.

If I strace rhn-applet-gui I get a loop like so:

read(8, 0xbffff030, 32)                 = -1 EAGAIN (Resource temporarily
unavailable)
select(9, [8], NULL, NULL, NULL)        = 1 (in [8])
read(8, "\1\1o+\0\0\0\0\7\0\200\1\0\0\0\0\0\0\0\0\0\0\0\0x^\31\n"..., 32) = 32
ioctl(8, FIONREAD, [0])                 = 0
gettimeofday({1049894139, 293449}, NULL) = 0
poll([{fd=8, events=POLLIN}, {fd=3, events=POLLIN}, {fd=7, events=POLLIN},
{fd=10, events=POLLIN|POLLPRI}, {fd=11, events=POLLIN|POLLPRI}, {fd=12,
events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}], 7, 34) = 0
gettimeofday({1049894139, 342163}, NULL) = 0
ioctl(8, FIONREAD, [0])                 = 0
gettimeofday({1049894139, 343175}, NULL) = 0
poll([{fd=8, events=POLLIN}, {fd=3, events=POLLIN}, {fd=7, events=POLLIN},
{fd=10, events=POLLIN|POLLPRI}, {fd=11, events=POLLIN|POLLPRI}, {fd=12,
events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}], 7, 0) = 0
gettimeofday({1049894139, 344255}, NULL) = 0
writev(8, [{"5\30\4\0\242\r\240\2\375\0\240\2\26\0\26\0007\r\6\0\243"..., 264},
{"\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\3\0\0"..., 1936}], 2) = 2200
write(8, "\233\10\t\0\3\r\240\2\246\r\240\2\247\r\240\2\244\r\240"..., 164) = 164

Maybe I'm just doing something horribly wrong.
Jason
Comment 3 Daniel Veillard 2003-04-09 09:40:49 EDT
Hum, the best way to restart it is from the red fedora menu,
go to system tools, then Red Hat Network alert icon
The program is not really technically an applet, make sure
you launch it from the main menu via system tools.

Daniel
Comment 4 Jason Corley 2003-04-09 10:11:52 EDT
Ok I tried starting it your way and still nothing is happening.

[jasonc@jcorley jasonc]$ ps auxwww | egrep "rhn|python" | grep -v grep
root      2339  0.0  0.0  3408  412 ?        S    Apr04   0:00 rhnsd --interval 240
jasonc   25019  0.2  2.6 24284 13512 ?       S    09:44   0:02 /usr/bin/python
/usr/bin/rhn-applet-gui
[jasonc@jcorley jasonc]$ 

Is there anything else I can do to bring it back?  Does it have a configuration
directory or cache that would survive rpm removal?  Because I've tried that with
the same result.
Jason
Comment 5 Daniel Veillard 2003-04-09 12:14:19 EDT
I have no idea where this may come from. See what's happend when
you log under Gnome, or as root or another account. But to get
stuck in the green state it means there is something really wrong
with the networking layer.

Daniel
Comment 6 Jason Corley 2003-04-09 13:21:58 EDT
Ok I did some tinkering and found it to be a product of my KDE settings. 
Basically, the rhn applet has stopped displaying in the panel (although it may
in fact be there) when I used the KDE Control Center and set Desktop -> Taskbar
-> Group Similar Tasks to Never.  It just disappeared after that.  When I logged
out and logged back in it was gone completely.  Also, oddly enough, the rhn icon
appeared in the same bracketing as System Tray, which is now blank.  Does this help?
Jason
Comment 7 Jason Corley 2003-04-09 13:24:28 EDT
Running Red Hat Network Alert Icon from the fedora menu brings it back though.  Odd.
Jason
Comment 8 Jason Corley 2003-04-09 19:15:32 EDT
Ok, the final answer is:
If you delete the system tray from your panel, the red hat network alert icon
will not reappear until you've re-added the system tray applet. I don't know if
there is any way for you to test that in rhn-applet-gui, but I figured you'd
want to know.
Jason
Comment 9 K.A. 2005-10-03 18:44:30 EDT
Thanks MAN
you helped me a lot.
SYSTEM TRAY applet has to be added first in order to have rhn-applet show up !!!!

That's tricky !!!


Note You need to log in before you can comment on or make changes to this bug.