Bug 883591 - [abrt] insight-7.4.50-4.20120403cvs.fc18: gdb_find_bp_at_line: Process /usr/bin/insight was killed by signal 11 (SIGSEGV)
Summary: [abrt] insight-7.4.50-4.20120403cvs.fc18: gdb_find_bp_at_line: Process /usr/b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: insight
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrick Monnerat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e6a6b24520ade96dae48580119b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-04 22:53 UTC by Niki Guldbrand
Modified: 2013-01-11 23:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-15 17:49:06 UTC


Attachments (Terms of Use)
File: backtrace (11.22 KB, text/plain)
2012-12-04 22:53 UTC, Niki Guldbrand
no flags Details
File: cgroup (127 bytes, text/plain)
2012-12-04 22:53 UTC, Niki Guldbrand
no flags Details
File: core_backtrace (12.19 KB, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: dso_list (2.71 KB, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: environ (1.58 KB, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: maps (17.14 KB, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: open_fds (301 bytes, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: proc_pid_status (925 bytes, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: smolt_data (3.16 KB, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details
File: var_log_messages (371 bytes, text/plain)
2012-12-04 22:54 UTC, Niki Guldbrand
no flags Details

Description Niki Guldbrand 2012-12-04 22:53:51 UTC
Description of problem:
Started Insight, loaded a program file, enabled a couple of breakpoints, and started the program, and Insight crashed.

Version-Release number of selected component:
insight-7.4.50-4.20120403cvs.fc18

Additional info:
backtrace_rating: 4
cmdline:        insight
crash_function: gdb_find_bp_at_line
executable:     /usr/bin/insight
kernel:         3.6.7-5.fc18.x86_64
remote_result:  768813
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (9 frames)
 #0 gdb_find_bp_at_line at gdbtk/generic/gdbtk-bp.c:257
 #2 wrapped_call at gdbtk/generic/gdbtk-cmds.c:439
 #3 catch_errors at exceptions.c:546
 #4 gdbtk_call_wrapper at gdbtk/generic/gdbtk-cmds.c:370
 #5 TclEvalObjvInternal at /usr/src/debug/tcl8.5.13/generic/tclBasic.c:3706
 #6 TclExecuteByteCode at /usr/src/debug/tcl8.5.13/generic/tclExecute.c:2416
 #7 TclCompEvalObj at /usr/src/debug/tcl8.5.13/generic/tclExecute.c:1538
 #8 TclEvalObjEx at /usr/src/debug/tcl8.5.13/generic/tclBasic.c:5275
 #9 ??

Comment 1 Niki Guldbrand 2012-12-04 22:53:55 UTC
Created attachment 657802 [details]
File: backtrace

Comment 2 Niki Guldbrand 2012-12-04 22:53:57 UTC
Created attachment 657803 [details]
File: cgroup

Comment 3 Niki Guldbrand 2012-12-04 22:54:00 UTC
Created attachment 657804 [details]
File: core_backtrace

Comment 4 Niki Guldbrand 2012-12-04 22:54:02 UTC
Created attachment 657805 [details]
File: dso_list

Comment 5 Niki Guldbrand 2012-12-04 22:54:04 UTC
Created attachment 657806 [details]
File: environ

Comment 6 Niki Guldbrand 2012-12-04 22:54:06 UTC
Created attachment 657807 [details]
File: limits

Comment 7 Niki Guldbrand 2012-12-04 22:54:09 UTC
Created attachment 657808 [details]
File: maps

Comment 8 Niki Guldbrand 2012-12-04 22:54:11 UTC
Created attachment 657809 [details]
File: open_fds

Comment 9 Niki Guldbrand 2012-12-04 22:54:13 UTC
Created attachment 657810 [details]
File: proc_pid_status

Comment 10 Niki Guldbrand 2012-12-04 22:54:16 UTC
Created attachment 657811 [details]
File: smolt_data

Comment 11 Niki Guldbrand 2012-12-04 22:54:18 UTC
Created attachment 657813 [details]
File: var_log_messages

Comment 12 Patrick Monnerat 2012-12-05 14:20:06 UTC
Thanks for the bug report.
I can't reproduce the problem. However it seems there is already a fix in upstream CVS: I take it as a patch.
You'll soon find a new package in testing repository. Please try it and update karma accordingly. Comment here if needed. Thanks in advance.

Comment 13 Fedora Update System 2012-12-05 14:29:48 UTC
insight-7.4.50-5.20120403cvs.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/insight-7.4.50-5.20120403cvs.fc17

Comment 14 Fedora Update System 2012-12-05 14:30:04 UTC
insight-7.4.50-5.20120403cvs.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/insight-7.4.50-5.20120403cvs.fc18

Comment 15 Fedora Update System 2012-12-05 14:30:15 UTC
insight-7.4.50-5.20120403cvs.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/insight-7.4.50-5.20120403cvs.fc16

Comment 16 Fedora Update System 2012-12-05 23:08:27 UTC
Package insight-7.4.50-5.20120403cvs.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing insight-7.4.50-5.20120403cvs.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19787/insight-7.4.50-5.20120403cvs.fc18
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2012-12-15 17:49:07 UTC
insight-7.4.50-5.20120403cvs.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2012-12-15 17:59:13 UTC
insight-7.4.50-5.20120403cvs.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2013-01-11 23:42:57 UTC
insight-7.4.50-5.20120403cvs.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.