Bug 8836 - gnome-help-browser crashes
gnome-help-browser crashes
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-25 09:10 EST by Tim Waugh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-02 09:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2000-01-25 09:10:54 EST
Red Hat Linux 6.1 GNOME workstation upgraded with 6.2beta2.
When logging in (as root), gnome-help-browser segfaults.

(gdb) run
Starting program: /usr/bin/gnome-help-browser

Program received signal SIGSEGV, Segmentation fault.
0x4055c1bc in chunk_alloc (ar_ptr=0x405f1080, nb=16) at malloc.c:2763
2763    malloc.c: No such file or directory.
(gdb) bt
#0  0x4055c1bc in chunk_alloc (ar_ptr=0x405f1080, nb=16) at malloc.c:2763
#1  0x4055c07e in __libc_malloc (bytes=5) at malloc.c:2696
#2  0x403bcca6 in g_malloc () from /usr/lib/libglib-1.2.so.0
#3  0x403c5183 in g_strdup () from /usr/lib/libglib-1.2.so.0
#4  0x8050f2a in newInfoTable ()
#5  0x804f754 in newToc ()
#6  0x804e698 in main ()
#7  0x4051b52b in __libc_start_main (main=0x804e4f0 <main>, argc=1,
    argv=0xbffff9e4, init=0x804cdd8 <_init>, fini=0x805745c <_fini>,
    rtld_fini=0x4000ac50 <_dl_fini>, stack_end=0xbffff9dc)
    at ../sysdeps/generic/libc-start.c:92
(gdb)

Looks like the heap is corrupt.

To reproduce: upgrade a 6.1 GNOME workstation (this bug doesn't happen on
clean installation of 6.2).
Comment 1 Elliot Lee 2000-02-01 18:59:59 EST
Could you try the gnome-libs-1.0.55-1 package that is in the 6.2 tree now, and
see if that helps?

This is a well-known bug, but I'm not sure if the fix was in gnome-libs 1.0.55
or if this problem still exists. Please advise.
Comment 2 Tim Waugh 2000-02-02 09:01:59 EST
That seems to work fine.

Note You need to log in before you can comment on or make changes to this bug.