Bug 883637 - (CVE-2012-4534) CVE-2012-4534 Tomcat - Denial Of Service when using NIO+SSL+sendfile
CVE-2012-4534 Tomcat - Denial Of Service when using NIO+SSL+sendfile
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20121204,repor...
: Security
Depends On: 883690 883691 883692 883693 883694
Blocks: 883674
  Show dependency treegraph
 
Reported: 2012-12-04 22:33 EST by Arun Babu Neelicattu
Modified: 2015-02-15 16:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 02:57:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arun Babu Neelicattu 2012-12-04 22:33:33 EST
When using the NIO connector with sendfile and HTTPS enabled, if a client breaks the connection while reading the response an infinite loop is entered leading to a denial of service.

Source: Tomcat security pages. [1,2]

[1] http://tomcat.apache.org/security-6.html
[2] http://tomcat.apache.org/security-7.html
Comment 3 David Jorm 2012-12-05 01:25:38 EST
Created tomcat6 tracking bugs for this issue

Affects: fedora-all [bug 883690]
Comment 4 David Jorm 2012-12-05 01:25:41 EST
Created tomcat tracking bugs for this issue

Affects: fedora-16 [bug 883691]
Comment 5 Fedora Update System 2012-12-19 03:29:26 EST
tomcat-7.0.33-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jan Lieskovsky 2012-12-19 08:54:24 EST
Upstream bug report (including reproducer):
  https://issues.apache.org/bugzilla/show_bug.cgi?id=52858
Comment 9 errata-xmlrpc 2013-02-19 15:30:59 EST
This issue has been addressed in following products:

  JBoss Enterprise Web Server 2.0.0

Via RHSA-2013:0265 https://rhn.redhat.com/errata/RHSA-2013-0265.html
Comment 10 errata-xmlrpc 2013-02-19 17:15:09 EST
This issue has been addressed in following products:

  JBEWS 2 for RHEL 5
  JBEWS 2 for RHEL 6

Via RHSA-2013:0266 https://rhn.redhat.com/errata/RHSA-2013-0266.html
Comment 11 errata-xmlrpc 2013-03-11 15:33:52 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:0623 https://rhn.redhat.com/errata/RHSA-2013-0623.html

Note You need to log in before you can comment on or make changes to this bug.