Bug 883641 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 29: ordinal not in range(128)
Summary: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 29: ordi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-meh
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 905672 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-05 03:46 UTC by Steve Tyler
Modified: 2013-01-30 11:43 UTC (History)
3 users (show)

Fixed In Version: python-meh-0.20-1.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-12 01:29:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Steve Tyler 2012-12-05 03:46:59 UTC
Description of problem:
UnicodeDecodeError exception doing dump.

Version-Release number of selected component (if applicable):
python-meh-0:0.18-1.fc18.noarch (on Live CD)
anaconda 18.35 (updated from what is on Live CD)
Fedora-18-Beta-x86_64-Live-Desktop.iso

How reproducible:
Only tried once.

Steps to Reproduce:
1. Start the installer from the Live CD.
2. Complete an install in Chinese (Taiwan).
3. Restart the installer.
4. Attempt to create a new volume group with name "fedora".
  
Actual results:
Bug 883632 - TypeError: set_info() takes exactly 2 arguments (3 given)

Attached file anaconda-tb has:
Exception occurred during state dump:
...
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 29: ordinal not in range(128)

https://bugzilla.redhat.com/attachment.cgi?id=657917

Expected results:
No exception doing dump.

Additional info:
See also:
Bug 874250 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 60: ordinal not in range(128)

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/Final/Fedora-18-Beta-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse

Comment 1 Steve Tyler 2012-12-05 03:50:09 UTC
[snippet from Attachment 657917 [details]]
Exception occurred during state dump:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 419, in dump
    ret += self._dumpClass(obj, skipList=idSkipList)
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 368, in _dumpClass
    ret += self._dumpClass(value, level + 1, parentkey=curkey, skipList=skipList)
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 368, in _dumpClass
    ret += self._dumpClass(value, level + 1, parentkey=curkey, skipList=skipList)
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 360, in _dumpClass
    ret += self._dumpClass(v, level + 1, parentkey = curkey, skipList=skipList)
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 368, in _dumpClass
    ret += self._dumpClass(value, level + 1, parentkey=curkey, skipList=skipList)
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 358, in _dumpClass
    ret += "%s" % (v,)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 29: ordinal not in range(128)

Comment 2 Vratislav Podzimek 2012-12-05 09:56:44 UTC
Patch posted to anaconda-patches.

Comment 3 Fedora Update System 2012-12-11 12:26:08 UTC
python-meh-0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-meh-0.20-1.fc18

Comment 4 Fedora Update System 2012-12-11 20:05:57 UTC
Package python-meh-0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-meh-0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20183/python-meh-0.20-1.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-01-12 01:29:15 UTC
python-meh-0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Vratislav Podzimek 2013-01-30 11:43:20 UTC
*** Bug 905672 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.