Bug 883673 - Web service returns error if datetime is zero
Summary: Web service returns error if datetime is zero
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Bugzilla
Classification: Community
Component: WebService
Version: 4.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Green
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-05 05:57 UTC by Wei Shen
Modified: 2014-10-12 22:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-17 02:59:13 UTC


Attachments (Terms of Use)

Description Wei Shen 2012-12-05 05:57:33 UTC
Description of problem:
version 4.2.4-6.1

Hwcert team is using web service to search bugs, but sometimes, we met with "Can't call method "iso8601" on an undefined value at Bugzilla/WebService/Server.pm line 69". After looking into this, I Found the cause was delta_ts = "0000-00-00 00:00:00". So the code of datetime_format_outbound in Bugzilla/WebService/Server.pm need to improve.
$time could be undef.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Should not error

Expected results:


Additional info:

Comment 1 Simon Green 2012-12-17 01:07:41 UTC
Do you have an example bug number (or search call) that shows this? I cannot find any bugs with a delta_ts of 0000-00-00.

Comment 2 Wei Shen 2012-12-17 02:42:30 UTC
No, I don't have one now. That date made our tools crash, so we fixed it by changing the delta_ts. I know that case is quite rare, but it could be true.

Comment 3 Simon Green 2012-12-17 02:59:13 UTC
If you come up with an example to reproduce the error, we can look into it. Until then, I'm marking this bug as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.