Bug 883739 - bootstrap: do not install SDL package - Spice server does not need it
bootstrap: do not install SDL package - Spice server does not need it
Status: CLOSED DUPLICATE of bug 861575
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Alon Bar-Lev
Yaniv Kaul
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-05 02:58 EST by Yaniv Kaul
Modified: 2013-07-03 22:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 09:09:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-12-05 02:58:59 EST
Description of problem:
AFAIK, Spice does not need SDL, we should not install it.

[root@master-vds9 ~]# yum remove SDL
Loaded plugins: product-id, rhnplugin, subscription-manager
Updating certificate-based repositories.
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package SDL.x86_64 0:1.2.14-2.el6 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                        Arch                                              Version                                                 Repository                                          Size
===================================================================================================================================================================================================================
Removing:
 SDL                                            x86_64                                            1.2.14-2.el6                                            @hybrid                                            469 k

Transaction Summary
===================================================================================================================================================================================================================
Remove        1 Package(s)

Installed size: 469 k
Is this ok [y/N]: n
Exiting on user Command
[root@master-vds9 ~]# rpm -qa |grep spice
spice-server-0.8.2-5.el6.x86_64

Version-Release number of selected component (if applicable):
3.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alon Bar-Lev 2012-12-05 08:55:14 EST
Are you sure all past versions all since rhel-5.5, vdsm22, do not need this?

Please remember that vdsm-bootstrap is expected to bootstrap all versions of vdsm since first released.
Comment 2 Alon Bar-Lev 2012-12-05 08:57:03 EST
I will rephrase comment#1... from vdsm-bootstrap master of 3.2 we use yum API to install packages, hence not using the explicit dependencies at all.

ovirt-host-deploy also uses yum API to achieve the task.

So this already resolved in 3.2, the question in comment#1 is for 3.1.z.
Comment 3 Yaniv Kaul 2012-12-05 09:02:27 EST
(In reply to comment #2)
> I will rephrase comment#1... from vdsm-bootstrap master of 3.2 we use yum
> API to install packages, hence not using the explicit dependencies at all.

This is exactly the problem - we explicitly ask for SDL. I'm pretty sure we don't need it anymore.

> 
> ovirt-host-deploy also uses yum API to achieve the task.
> 
> So this already resolved in 3.2, the question in comment#1 is for 3.1.z.

No, not important at all for 3.1.z.
Comment 4 Alon Bar-Lev 2012-12-05 09:09:44 EST

*** This bug has been marked as a duplicate of bug 861575 ***

Note You need to log in before you can comment on or make changes to this bug.