Bug 883773 - Backend: CPU pinning works only with single-digit CPU's
Backend: CPU pinning works only with single-digit CPU's
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2.0
Assigned To: Laszlo Hornyak
Ido Begun
sla
: ZStream
Depends On:
Blocks: 886166
  Show dependency treegraph
 
Reported: 2012-12-05 04:58 EST by Ido Begun
Modified: 2016-02-10 15:16 EST (History)
13 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 886166 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (4.69 MB, text/x-log)
2012-12-05 04:58 EST, Ido Begun
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10714 None None None Never

  None (edit)
Description Ido Begun 2012-12-05 04:58:14 EST
Created attachment 658108 [details]
engine.log

Description of problem:
Currently, CPU pinning only works for physical/virtual CPU's with single decimal digit CPU.


Version-Release number of selected component (if applicable):
rhevm-3.1.0-31.el6ev

How reproducible:
100%

Steps to Reproduce:
Create a VM with CPU pinning of 0#10
  
Actual results:
[CPU pinning format invalid.]

Expected results:
VM should be created successfully (VM won't be able to start if pCPU #10 doesn't exist, but creation/edit should work fine)

Additional info:
Comment 1 Laszlo Hornyak 2012-12-05 05:05:43 EST
upstream patch http://gerrit.ovirt.org/#/c/9738/
Comment 2 Laszlo Hornyak 2012-12-07 04:52:39 EST
merged upstream, waiting for flags
Comment 5 Ido Begun 2013-01-07 05:24:30 EST
(In reply to comment #4)
> OK - SF3
> 
> VM creation now works properly when setting CPU pinning with
> physical/virtual CPU's with more than a single decimal ID number.

Disregarding my last comment, VMs API page breaks down when using setting CPU pinning with more than a single decimal digit ID number:

exception

org.jboss.resteasy.spi.UnhandledException: java.lang.NullPointerException
	org.jboss.resteasy.core.SynchronousDispatcher.handleApplicationException(SynchronousDispatcher.java:351)
	org.jboss.resteasy.core.SynchronousDispatcher.handleException(SynchronousDispatcher.java:220)
	org.jboss.resteasy.core.SynchronousDispatcher.handleInvokerException(SynchronousDispatcher.java:196)
	org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:551)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:513)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:125)
	org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:847)

root cause

java.lang.NullPointerException
	org.ovirt.engine.api.common.util.LinkHelper.getCollection(LinkHelper.java:479)
	org.ovirt.engine.api.common.util.LinkHelper.getUriBuilder(LinkHelper.java:525)
	org.ovirt.engine.api.common.util.LinkHelper.setHref(LinkHelper.java:576)
	org.ovirt.engine.api.common.util.LinkHelper.addLinks(LinkHelper.java:630)
	org.ovirt.engine.api.restapi.resource.AbstractBackendResource.addLinks(AbstractBackendResource.java:210)
	org.ovirt.engine.api.restapi.resource.AbstractBackendResource.addLinks(AbstractBackendResource.java:201)
	org.ovirt.engine.api.restapi.resource.BackendVmsResource.mapCollection(BackendVmsResource.java:375)
	org.ovirt.engine.api.restapi.resource.BackendVmsResource.list(BackendVmsResource.java:70)
	sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	java.lang.reflect.Method.invoke(Method.java:601)
	org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:167)
	org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:257)
	org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:222)
	org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:211)
	org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:536)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:513)
	org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:125)
	org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
	org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
Comment 6 Laszlo Hornyak 2013-01-09 09:31:01 EST
upstream patch http://gerrit.ovirt.org/#/c/10714/
Comment 9 Ido Begun 2013-01-30 05:22:21 EST
OK - SF4

VM creation and edit now work properly when setting CPU pinning with physical/virtual CPU's with more than a single decimal ID number.
Comment 10 Itamar Heim 2013-06-11 04:42:53 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:42:53 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:42:55 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:49:50 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.