Bug 8838 - NFS server does not release device after it is unmounted.
NFS server does not release device after it is unmounted.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-25 10:19 EST by Joseph Kotran
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 15:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Kotran 2000-01-25 10:19:03 EST
To recreate this bug you may do the following:

o Mount a CD-ROM
o Share the CD-ROM mount point to the network
o NFS mount the shared CD-ROM on a remote client
o On the remote client umount the NFS share

At this point you will not be able umount the CD-ROM on the nfs server
until you shutdown the nfs daemons.  The process that I have outlined
worked on all Red Hat releases up until 5.2.  Since 6.0 you have to
shutdown the nfs server to umount the CD-ROM.  I have recreated this
behavior on i386, Sparc, and Sparc64 platforms.

Regards,

Joe Kotran
Comment 1 Jeremy Katz 2000-01-27 20:20:59 EST
This is a difference between 2.2.x + knfsd and 2.0.x + user-space nfsd, and is
the expected behavior.  Cross-reference this message on linux-kernel,
http://www.tux.org/hypermail/linux-kernel/1999week18/0802.html
Comment 2 gozerian 2000-02-11 13:54:59 EST
Same here on stock 6.1, very annoying...
Comment 3 Alan Cox 2000-02-17 10:31:59 EST
Verified here. knfsd seems to be hanging on to handles to mount
points. It may be a feature but its not a nice one
Comment 4 Cristian Gafton 2000-08-08 22:34:34 EDT
assigned to johnsonm
Comment 5 Stephen John Smoogen 2003-01-24 15:03:58 EST
Bug 8838 has been closed because it seems fixed with the NFS in 7.2/7.3/8.0
releases. The additional step that you have to do is to stop nfs from exporting
/mnt/cdrom and then you can unmount /mnt/cdrom safely.

Note You need to log in before you can comment on or make changes to this bug.