Bug 883804 - ricci/luci_admin: man pages have executable flags set
ricci/luci_admin: man pages have executable flags set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.9
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-05 06:12 EST by Jan Pokorný
Modified: 2013-09-30 20:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: conga-0.12.2-66.el5
Doc Type: Bug Fix
Doc Text:
Proposed text: Previously, ricci and luci_admin manual pages from respective conga packages were installed with wrong permissions. To fix this bug, file permissions were corrected in the installation procedure and manual pages are now installed correctly.
Story Points: ---
Clone Of: 883585
Environment:
Last Closed: 2013-09-30 20:40:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-12-05 06:12:51 EST
+++ This bug was initially created as a clone of Bug #883585 +++

# ls -l /usr/share/man/man8/ricci.8.gz
-rwxr-xr-x 1 root root 307 Jan 12  2012 /usr/share/man/man8/ricci.8.gz

# rpm -qf /usr/share/man/man8/ricci.8.gz
ricci-0.12.2-51.el5
Comment 1 Jan Pokorný 2012-12-05 07:56:19 EST
# ls -l /usr/share/man/man8/luci_admin.8.gz
-rwxr-xr-x 1 luci luci 664 Jan 12  2012 /usr/share/man/man8/luci_admin.8.gz

# rpm -qf /usr/share/man/man8/luci_admin.8.gz
luci-0.12.2-51.el5
Comment 3 RHEL Product and Program Management 2013-04-04 08:29:44 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Ryan McCabe 2013-04-15 10:32:04 EDT
commit 89421aa64c6618eb16f9f1425c4fbbe6c4517692
Author: Ryan McCabe <rmccabe@redhat.com>
Date:   Mon Apr 15 10:30:19 2013 -0400

    conga: Install man pages with mode 644
    
    Previously no -m flag was passed to the 'install' command, so
    manual pages were being installed mode 755.
    
    Resolves: rhbz#883804
    
    Signed-off-by: Ryan McCabe <rmccabe@redhat.com>

(conga-luci-1stgen.git at fedorahosted)
Comment 8 errata-xmlrpc 2013-09-30 20:40:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1358.html

Note You need to log in before you can comment on or make changes to this bug.