Bug 88404 - netstg1.img file missing
netstg1.img file missing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda-images (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 16:51 EDT by Jason
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 19:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2003-04-09 16:51:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Where is the netstg1.img file used for a ftp install?  It is not on the ISO 
CD.  The mirrors I have checked don't have it either.

Version-Release number of selected component (if applicable):
anaconda-images-9.0-3.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.  Try to install RedHat 9 from a ftp site
2.  I copied all of the files from the 3 CDs to a folder
3.  on the ftp server.  The ftp install starts I answer the first questions and 
the installer says it can't find netstg1.img.
    

Actual Results:  The ftp install fails

Expected Results:  The ftp install should have worked

Additional info:
Comment 1 Michael Fulbright 2003-05-05 16:05:35 EDT
The netstg1.img image will be in RedHat/base under the FTP root you specified.
Comment 2 Jason 2003-05-06 11:09:24 EDT
That is where the file is suppose to be.  However when I downloaded the ISO
images from your ftp site, burned them to CD, copied the CDs to my server, made
the network boot disk, booted from the disk, selected ftp installed and I get an
error saying that netstg1.img is not found.  I checked the CDs and netstg1.img
file is not on it anywhere.  
ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/base doesn't have the file
exiteither.  I checked a few mirrors and they didn't have it either.

ftp://chuck.ucs.indiana.edu/pub/linux/redhat/redhat/linux/9/en/os/i386/RedHat/base
ftp://mirror.cs.wisc.edu/pub/mirrors/linux/redhat/9/en/os/i386/RedHat/base
ftp://ftp.webtrek.com/pub/mirrors/redhat/linux/9/en/os/i386/RedHat/base

I think someone forgot to include the file.

Jason
Comment 3 Michael Young 2003-05-06 14:32:12 EDT
Are you sure there is a netstg1.img at all in 9? You now need a second boot
floppy to do net installs, but I believe this downloads netstg2.img directly, so
it may be that the warning itself is wrong, or out of date.
Comment 4 Jason 2003-05-06 15:13:46 EDT
I don't know if netstg1.img is needed or not.  I used rawrite to create a
bootdisk from the bootdisk.img file in the images directory.  I booted the PC
from this disk, selected FTP install it will not complete the install without
netstg1.img

Where is the second disk?  I did not know about it.

Jason
Comment 5 Michael Young 2003-05-06 15:26:17 EDT
Read the release notes. bootdisk.img only works for IDE or USB harddisk/CD
installs. For everything else you need to add drivers, in this case probably
from drvnet.img.
Comment 6 Jason 2003-05-06 15:30:11 EDT
I don't need the driver disk.  The PCs we use have intel etherexpress 100 cards
integrated into the motherboards (D850GB and D845PT motherboards).  The bootdisk
boots, gets an IP and I can ping the PC from the server while message saying
netstg1.img is not found.
Comment 7 Michael Young 2003-05-06 17:48:22 EDT
It sounds to me like the floppy you are using is not the genuine RedHat 9 boot
disk, because the real disk doesn't have network drivers on, nor as far as I can
tell does it mention netstg1.img. You may have confused it with a disk from an
earlier version of RedHat.
Comment 8 Jason 2003-05-06 18:50:41 EDT
You are correct, after looking at the bootdisk, I discovered that it was the
redhat 8 bootdisk in disguse.  This is the last time I trust my assistant to do
this.  I went to the CD ran rawrite, booted the disk, and it is now asking for
the driver disk.  How can I put the correct driver on the disk so I only need
one disk?  I am sorry for the confusion I have caused.

Jason
Comment 9 Michael Young 2003-05-07 05:11:02 EDT
That is not simple, even assuming there is enough space on the boot disk to take
the drivers. You need to uncompress and mount the initrd on the boot disk, and
add the extra modules to the modules.cgz file on it (which is a gzipped cpio crc
format file) and probably edit some other files like modules.dep as well, then
recompress the modified initrd file and put it back on the boot disk, if there
is space.
Comment 10 Jason 2003-05-07 11:22:32 EDT
You are correct the above is not simple.  Here I thought I would get a copy of
the .config file for the kernel on the bootdisk.  I would then add the driver I
need (not as a module), compile a kernel based on the new .config, make a new
initrm.img (I might be able to reuse the initrd file becuase I wouldn't change
any of the modules), and copy the resulting kernel and initrd to the bootdisk. 
Is what I suggest possible or is it more complex than what you suggested?
Comment 11 Michael Young 2003-05-07 18:54:31 EDT
Building the kernel might be simpler, particularly if you have done it before.
If you use the kernel-source package, you can find the .config file for the boot
kernel in the configs directory. If so you probably only need to replace the
kernel on the boot disk, but you may still run into space problems.
Comment 12 Jason 2003-05-08 19:05:29 EDT
I have rebuilt a few kernels over time.  I have tried twice today to build a
kernel for this project and both times they were just a little too big for the
floppy.  Each time I compile I get rid of more options and each time the
resulting kernel is smaller, so hopefully I will get a small enough kernel
shortly.  Thank you for you assistance.  I really appreicate it.  

Jason

Note You need to log in before you can comment on or make changes to this bug.