Bug 88411 - machine freezes for 20 seconds after PCMCIA CompactFlash adapter insertion
machine freezes for 20 seconds after PCMCIA CompactFlash adapter insertion
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 18:08 EDT by Need Real Name
Modified: 2015-01-04 17:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 23:31:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-09 18:08:45 EDT
From Bugzilla Helper:
User-Agent: Opera/6.12 (Linux 2.4.18-27.7.x i686; U)  [en]

Description of problem:
complete machine locks up, but after 20s it comes back to life.
The inserted CompactFlash appears to work (after the machine
recovers).  The problem was reproduced with 3 types of CompactFlash.
Exactly the same hardware (machine, CF-adapter, CF) works perfectly
with Red Hat 7.3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. insert pcmcia CF-adapter (with CF)
2.
3.
   

Actual Results:  pcmcia system beeps once, machine completely freezes for 20s
(mouse-cursor doesn't move, remote connections to the machine stall etc.).
After the approx. 20s you get the second pcmcia beep and machine returns
to normal.  The kernel has generated these error messages:

hdc: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hdc: task_no_data_intr: error=0x00 { }

and after the errors the normal messages like:

hdc: 251904 sectors (129 MB) w/1KiB Cache, CHS=492/16/32
 hdc: hdc1 hdc2
ide_cs: hdc: Vcc = 3.3, Vpp = 0.0


Expected Results:  No 20s delay with freezing and no IDE error message.

Additional info:

Dell Inspiron 8100 laptop (1.2 GHz PIII)
kernel 2.4.20-9
kernel-pcmcia-cs-3.1.31-13

(everything works flawlessly with RH 7.3 !)
Comment 1 David Wilson 2003-05-12 22:50:27 EDT
I had a similar experience on my NEC Versa Vxi (unfortunately I did not think 
to time it). I just tried it again with two cards (CF 128MB in PCMCIA adapter 
and SanDisk 85MB) and this time it was quicker. The first card stalled the 
system for 6-7 seconds and plugging in the 2nd card (leaving the first still 
inserted) only took about 2 seconds.
Comment 2 David Wilson 2003-05-12 22:52:53 EDT
P.S. I get the same task_no_data_intr errors in my log except that the 2nd one 
is error=0x04 { DriveStatusError } for both my cards.

Note You need to log in before you can comment on or make changes to this bug.