Bug 88416 - up2date -u shows error error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
up2date -u shows error error: db4 error(-30989) from dbcursor->c_get: DB_PAGE...
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 19:14 EDT by Kent Pirkle
Modified: 2007-04-18 12:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:35:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kent Pirkle 2003-04-09 19:14:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I get this error message when I run up2date. This is the same bug as 85440 but
bugzilla would not let me add comments to it.  I don't get this on other Red Hat
Linux 9 systems. This system is a VIA C3/800MHz CPU based system. 

Version-Release number of selected component (if applicable):
up2date-3.1.23-1

How reproducible:
Always

Steps to Reproduce:
1. Run up2date -u
2.
3.
    

Actual Results:  [root@solarstorm root]# up2date -u -f
                                                                                
Fetching package list for channel: redhat-linux-i386-9...
########################################
                                                                                
Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################
                                                                                
Testing package set / solving RPM inter-dependencies...
########################################
glibc-2.3.2-27.9.i386.rpm:  ########################## Done.
glibc-common-2.3.2-27.9.i38 ########################## Done.
glibc-devel-2.3.2-27.9.i386 ########################## Done.
httpd-2.0.40-21.1.i386.rpm: ########################## Done.
httpd-manual-2.0.40-21.1.i3 ########################## Done.
mod_ssl-2.0.40-21.1.i386.rp ########################## Done.
nscd-2.3.2-27.9.i386.rpm:   ########################## Done.
Preparing              ########################################### [100%]
                                                                                
Installing...
   1:glibc-common           ########################################### [100%]
   2:glibc                  ########################################### [100%]
Stopping sshd:[  OK  ]
Starting sshd:[  OK  ]
   3:httpd                  ########################################### [100%]
   4:glibc-devel            ########################################### [100%]
   5:httpd-manual           ########################################### [100%]
   6:mod_ssl                ########################################### [100%]
   7:nscd                   ########################################### [100%]
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found

The profile on RHN is also not updated.

Additional info:
Comment 1 Mike Shaver 2003-04-12 18:02:29 EDT
I get this error when trying to install xboxgw RPMs (hmlibs in this case -- let
me know if you want a copy):

: rpm; sudo rpm -Uvh xboxgw-1.08-2.i386.rpm hmlibs-1.07-2.i386.rpm
Preparing...                ########################################### [100%]
   1:hmlibs                 ########################################### [ 50%]
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: error(-30989) getting "/usr/include/" records from Dirnames index
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: error(-30989) getting "/usr/lib/" records from Dirnames index
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: error(-30989) getting "/usr/sbin/" records from Dirnames index
   2:xboxgw                 ########################################### [100%]
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: error(-30989) getting "/usr/local/" records from Dirnames index
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: error(-30989) getting "/usr/local/doc/" records from Dirnames index
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: error(-30989) getting "/usr/sbin/" records from Dirnames index

Rebuilding doesn't help, even if I remove the __db.00* files:
: rpm; sudo rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy
Comment 2 Mike Shaver 2003-04-12 18:05:06 EDT
The packages (both) seem to have been installed, though, and rpm -V doesn't
report any problems.
Comment 3 Adrian Likins 2004-08-20 16:34:03 EDT
I belive that error message is harmless, but I'll
reassign to rpm just to be sure.
Comment 4 Paul Nasrat 2005-09-29 15:35:08 EDT
Due to the lenght of time involved and the notoriously hard to reproduce
pagenotfound error it is hard investigate the issue further, we will assume the
problem was not reproduceable or has been fixed in a later update for this product.

If you have further details against current product please reopen.

Note You need to log in before you can comment on or make changes to this bug.