Bug 884251 - download via magnet cannot work in current version
Summary: download via magnet cannot work in current version
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-05 17:56 UTC by pizza306
Modified: 2013-01-29 00:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-29 00:43:26 UTC
Type: Bug


Attachments (Terms of Use)

Description pizza306 2012-12-05 17:56:55 UTC
Description of problem:
i want to download files via magnet link and it can see peers, but deluge can't connect to any of them (it shows like 'seeds: 0(546) peers: 57(23)'), .torrent function is fine without any problems.

Version-Release number of selected component (if applicable):
deluge-*-1.3.5-2.fc18
works under classic mode ('not daemon' mode)

How reproducible:
every magnet links

Steps to Reproduce:
1. open any magnet links and import into deluge
2. you can see peers, but you can't connect them
   "seeds: 0(546) peers: 57(23)"
3.
  
Actual results:
stood there and can't work

Expected results:
import, connect and download successfully

Additional info:
i later grab the -dev version and -dev works fine with magnet, so do .torrent
maybe it would be great if we can package the -dev version and update directly from yum/packagekit.

Comment 1 Jason Farrell 2013-01-11 02:41:02 UTC
Confirmed & thanks pizzaman,

I was going crazy for a while thinking it was a problem with me not understanding how the new firewalld in f18 worked, but after finally just disabling the firewall for a bit the problem remained, and extra server (deluged -d -L debug) and client debug logs didn't help much.

(Now to check the updates-testing then dev repos for an updated deluge...)

Comment 2 Calum 2013-01-28 13:01:26 UTC
This is a known issue due to libtorrent 0.16 disabling crashing extensions from python bindings, see http://dev.deluge-torrent.org/ticket/2160

To fix this all you will need to do is change flags=0 to flags=1 in core.py. 

The next release will have this fix.


Note You need to log in before you can comment on or make changes to this bug.