Bug 884377 - ValueError: cannot initialize a disk that has partitions
Summary: ValueError: cannot initialize a disk that has partitions
Keywords:
Status: CLOSED DUPLICATE of bug 976517
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b9d2ef320a61febdaf7e52423b5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-06 05:16 UTC by Steve Tyler
Modified: 2013-06-21 01:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-21 01:00:34 UTC
Type: ---


Attachments (Terms of Use)
anaconda-tb-xpzZXt (1.75 MB, text/plain)
2012-12-06 05:25 UTC, Steve Tyler
no flags Details
anaconda-tb-HflODf for reproducer (699.69 KB, text/plain)
2012-12-07 06:07 UTC, Steve Tyler
no flags Details

Description Steve Tyler 2012-12-06 05:16:17 UTC
Description of problem:
Attempted to remove existing /boot to create new /boot because reformat was not accepted.

Version-Release number of selected component:
anaconda-18.36-1.fc18.x86_64

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.36 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 845, in initializeDisk
:    raise ValueError("cannot initialize a disk that has partitions")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1874, in _destroy_device
:    self.__storage.initializeDisk(device.disk)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1966, in on_remove_clicked
:    self._destroy_device(device)
:ValueError: cannot initialize a disk that has partitions

Comment 1 Steve Tyler 2012-12-06 05:25:07 UTC
Created attachment 658528 [details]
anaconda-tb-xpzZXt

Logs were not automatically attached ...

Comment 2 David Lehman 2012-12-06 17:16:23 UTC
We'll need a full procedure to be able to replicate this failure.

Comment 3 Steve Tyler 2012-12-07 05:42:53 UTC
Attempting to reproduce Bug 884377.

Package: anaconda-18.36-1.fc18.x86_64
OS Release: Fedora release 18

Comment 4 Steve Tyler 2012-12-07 06:07:01 UTC
Created attachment 659213 [details]
anaconda-tb-HflODf for reproducer

Here's a reproducer and corresponding log:

Create a 12 GB disk image:
$ qemu-img create f18-test-2.img 12G

Boot the Live CD and update the installer:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/Final/Fedora-18-Beta-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse

Complete an install with the default storage configuration.

Restart the installer.

Proceed to Manual Partitioning.

Click "+" to expand Fedora Linux ...
Click Root to select.
Click "-" to delete.
Click Delete It. (Do not check "Delete all ...")

Click "+" to add a new mount point:
    Mount Point: /boot
    Desired Capacity: 500
Click Add mount point.

Click "+" to expand New ... Installation
[Boot should already be selected.]
Click "+" to expand Customize...
Change Device Type from LVM to Standard Partition.
Click Apply Changes.
[This fails with "Storage configuration reset due to unrecoverable error. ...".]

Click "+" to expand Fedora Linux ...
[Boot should already be selected.]
Click "-" to delete.
Click Delete It. (Do not check "Delete all ...")
Exception occurs: ValueError: cannot initialize a disk that has partitions

Comment 5 Brian Lane 2013-06-21 01:00:34 UTC

*** This bug has been marked as a duplicate of bug 976517 ***


Note You need to log in before you can comment on or make changes to this bug.