Bug 884595 - Enable Quantum linux bridge VIF driver to use "bridge" type
Enable Quantum linux bridge VIF driver to use "bridge" type
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
high Severity high
: snapshot2
: 2.1
Assigned To: Gary Kotton
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 06:11 EST by Alan Pevec
Modified: 2016-04-26 19:14 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-nova-2012.2.2-9.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 856149
Environment:
Last Closed: 2013-02-14 13:23:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1078210 None None None Never

  None (edit)
Description Alan Pevec 2012-12-06 06:11:33 EST
+++ This bug was initially created as a clone of Bug #856149 +++

> There are 2 pending reviews that can be backported to Folsom - these improve
> the usage of the linuxbridge plugin:
> Quantum - https://review.openstack.org/#/c/14961/
This is in quantum-2012.2.1

> Nova - https://review.openstack.org/#/c/14830/

stable/folsom backport is https://review.openstack.org/#/c/17036/
I'll clone BZ to rhos-2.0 to include this patch in Folsom Preview async update.
Comment 2 Nikola Dipanov 2012-12-13 11:25:58 EST
Since this change wasn't approved as a backport - we are going to need to backport it so I am assigning this to Martin Magr to do the backporting work for Folsom.
Comment 6 Ofer Blaut 2013-02-07 05:48:29 EST
Tested 

Instances are using linux bridge and 
/var/lib/nova/instances/instance-00000010/libvirt.xml is using 

<interface type="bridge">
      <mac address="fa:16:3e:2b:ce:98"/>
      <model type="virtio"/>
      <source bridge="brqd71755b4-0e"/>
      <target dev="tap67dfcaef-34"/>


openstack-quantum-2012.2.1-6.el6ost.noarch
Comment 8 errata-xmlrpc 2013-02-14 13:23:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html

Note You need to log in before you can comment on or make changes to this bug.