Bug 88461 - Firstboot doesnt show Danish special letters and cuts off ...
Firstboot doesnt show Danish special letters and cuts off ...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-10 05:10 EDT by Kenneth Rohde Christiansen
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-16 15:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Rohde Christiansen 2003-04-10 05:10:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4b) Gecko/20030409

Description of problem:
Firstboot doesnt show Danish special letters and cuts off the labels just before
the first occurance of a Danish special letter.

e.g.:

"Bem�rk at dette g�r noget slemt"

becomes

"Bem"

This makes firstboot unusable!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set language to da_DK
2. Start it
3.
    

Additional info:
Comment 1 Brent Fox 2003-05-16 15:41:12 EDT
After some digging, it turns out that the problem was being caused by non-UTF-8
po files in redhat-config-date and redhat-config-soundcard.  Firstboot calls
these modules to draw the date and soundcard screen, so the broken encoding were
being passed up the line to firstboot, which started truncating the strings once
it reached a char that it didn't understand.  My guess is that it was happening
in a few other languages besides Danish too.  This should be fixed in
redhat-config-date-1.5.9-9 and redhat-config-soundcard-1.0.4-3. 

Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.