Bug 884657 - the server-6-ost-folsom channels need to be mapped into channel-cert-mapping.txt
the server-6-ost-folsom channels need to be mapped into channel-cert-mapping.txt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
nobody nobody
:
Depends On:
Blocks: rhsm-rhel65 rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-12-06 08:58 EST by John Sefler
Modified: 2013-11-21 16:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:22:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-06 08:58:12 EST
Description of problem:

CDN Product Baseline RHN Channel 'rhel-x86_64-server-6-ost-folsom' is accounted for in the subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

CDN Product Baseline RHN Channel 'rhel-x86_64-server-6-ost-folsom-debuginfo' is accounted for in the subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>


Version-Release number of selected component (if applicable):
[root@jsefler-6server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.2.6-1.git.0.171d4c3.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6server ~]# grep ost-folsom /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-6server ~]# 


Expected results:
rhel-x86_64-server-6-ost-folsom: Server-OpenStack-x86_64-b83069ace8bd-191.pem
rhel-x86_64-server-6-ost-folsom-debuginfo: Server-OpenStack-x86_64-b83069ace8bd-191.pem
Comment 1 Alex Wood 2012-12-06 14:54:58 EST
There's a slight problem here.  The ID 191 maps to two different certificates.

% find -name '*191*.pem'
./product_ids/openstack/Server-OpenStack-x86_64-b83069ace8bd-191.pem
./product_ids/openstack/Server-OpenStack-x86_64-0b9893c79701-191.pem

Consequently, the script that generates the channel-cert-mapping file doesn't know which certificate to map to.
Comment 2 John Sefler 2012-12-06 15:47:11 EST
Although both of the product ids are the same (191), they appear to be different versions of the same product....

[root@jsefler-6 rhnDefinitionsDir]# rct cat-cert product_ids/openstack/Server-OpenStack-x86_64-0b9893c79701-191.pem | grep Product: -A6
Product:
	ID: 191
	Name: Red Hat OpenStack
	Version: Folsom
	Arch: x86_64
	Tags: None

[root@jsefler-6 rhnDefinitionsDir]# rct cat-cert product_ids/openstack/Server-OpenStack-x86_64-b83069ace8bd-191.pem | grep Product: -A6
Product:
	ID: 191
	Name: Red Hat OpenStack
	Version: Essex
	Arch: x86_64
	Tags: openstack


Clearly, the RHN *folsum* channels correspond to Server-OpenStack-x86_64-0b9893c79701-191.pem, but that's not so programatically obvious from parsing the product-baseline.json.

Definitely NEEDINFO
Comment 3 Jay Greguske 2012-12-11 13:41:19 EST
I'm not sure info to provide other than "products will have multiple versions". There will be multiple certificates for RHEV: 3.0 and 3.1 later today and JBoss EWS (1.x and 2.x) later this week.
Comment 4 Dennis Gregorovic 2012-12-11 13:48:11 EST
Note that each version of OpenStack will make to a different set of RHN channels.

rhel-x86_64-server-6-ost-preview -> Essex
rhel-x86_64-server-6-ost-folsom -> Folsom

So, we should be able to handle that mapping in the migration tool.  However, we may need to move the certs around so that the tool knows which cert to use for each channel.  Alex, what do you think?
Comment 5 RHEL Product and Program Management 2012-12-15 01:49:19 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 Dennis Gregorovic 2013-09-18 16:47:44 EDT
The ost folsom channels are in the latest product-certs.json.

$ grep ost product-certs.json
    "rhel-x86_64-server-6-ost-3": {
    "rhel-x86_64-server-6-ost-3-cts": {
    "rhel-x86_64-server-6-ost-3-cts-debuginfo": {
    "rhel-x86_64-server-6-ost-3-debuginfo": {
    "rhel-x86_64-server-6-ost-folsom": {
    "rhel-x86_64-server-6-ost-folsom-debuginfo": {
    "rhel-x86_64-server-6-ost-preview": {
    "rhel-x86_64-server-6-ost-preview-debuginfo": {
Comment 10 John Sefler 2013-09-24 12:02:37 EDT
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.3.2-1.el6.noarch

[root@jsefler-6 ~]# grep ost /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ost-folsom: Server-OpenStack-x86_64-0b9893c79701-191.pem
rhel-x86_64-server-6-ost-folsom-debuginfo: Server-OpenStack-x86_64-0b9893c79701-191.pem
rhel-x86_64-server-6-ost-preview: Server-OpenStack-x86_64-b83069ace8bd-191.pem
rhel-x86_64-server-6-ost-preview-debuginfo: Server-OpenStack-x86_64-b83069ace8bd-191.pem
[root@jsefler-6 ~]# 


VERIFIED: The folsom and preview mappings are now included in subscription-manager-migration-data, but it now looks like we need mappings for ost-3 too.  That'll get opened as a new bug.

Regarding the mapping of multiple channels to a product cert that shares a common product ID (e.g 191).  This will be handled by bug 1006985
Comment 11 errata-xmlrpc 2013-11-21 16:22:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.