Bug 884682 - EWS cart should include Wed Framework Kit
Summary: EWS cart should include Wed Framework Kit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Dan Mace
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-06 14:46 UTC by Bill DeCoste
Modified: 2015-05-14 23:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-24 19:32:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bill DeCoste 2012-12-06 14:46:57 UTC
Description of problem:
EWS cart should include Wed Framework Kit. User needs to manually add Spring, Hibernate, etc.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Create EWS cart
2. 
3.
  
Actual results:
User needs to manually add WFK components


Expected results:
WFK components should be included automatically


Additional info:

Comment 1 Dan McPherson 2013-01-29 02:53:13 UTC
How would we pick the framework?  Why aren't they quickstart choices like Rails.

Comment 2 Bill DeCoste 2013-01-29 16:45:13 UTC
This is the Web Framework Kit: http://www.redhat.com/products/jbossenterprisemiddleware/web-framework-kit/

It sits on top of EWS. The rpms are released so this is a matter of adding a dependency on the right rpms and testing the install. Should probably be a US as this is a new feature not a bug.

Comment 3 Bill DeCoste 2013-06-24 19:32:57 UTC
Closing. This is all licensing not bits.


Note You need to log in before you can comment on or make changes to this bug.