This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 884739 - graceful automatic handling of connection to unix socket-based connections
graceful automatic handling of connection to unix socket-based connections
Status: CLOSED DUPLICATE of bug 810576
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 11:18 EST by David Jaša
Modified: 2013-04-08 22:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-08 22:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-12-06 11:18:53 EST
Description of problem:
Currently, virt-manager:
  * doesn't connect automatically if libvirtd service comes up
  * throws exceptions when the service is stopped/restarted
these two make user experience way worse than necessary for no real reason.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-15.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. configure libvirtd so that it doesn't require password to access qemu:///system
2. connect with virt-manager to qemu:///system session
3. stop libvirtd service
4. start libvirtd service
  
Actual results:
exception is thrown, virt-manager stays disconnected after the service comes up again

Expected results:
3. nothing happens on clean libvirtd exit, virt-manager just gracefully disconnects. Notification may be popped up if libvirt crashes (but that's not necessary)
4. libvirt watches for libvird socket, when it appears (or libvirt starts listening on it again), virt-manager automatically reconnects

Additional info:
Comment 1 Geyang Kong 2012-12-28 04:29:27 EST
Looks we've already got bug 810576 for this issue.
Comment 2 Dave Allan 2013-04-08 22:22:35 EDT

*** This bug has been marked as a duplicate of bug 810576 ***

Note You need to log in before you can comment on or make changes to this bug.