Bug 884819 - abrt-applet alerts about already reported bugs if it wasn't running at the time.
Summary: abrt-applet alerts about already reported bugs if it wasn't running at the time.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-06 19:04 UTC by Sergio
Modified: 2016-12-01 00:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-12 01:17:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Sergio 2012-12-06 19:04:25 UTC
Description of problem: if bugs are reported when abrt-applet isn't running when it runs it alerts about them instead of ignoring.


Version-Release number of selected component (if applicable):
abrt-gui-2.0.19-2.fc18.i686

Steps to Reproduce:
1. report a bug with abrt-gui when abrt-applet isn't running.
2. login to a session that auto-starts abrt-applet.
3.
  
Actual results: abrt-applet notifies of the crash.


Expected results: abrt-applet should ignore the already reported bugs.


Additional info:

Comment 1 Sergio 2012-12-08 21:22:04 UTC
Actually the issue must be something else. Because I had a crash earlier today, 'reported' it to a log file (bug went to the reported bugs list) and now that I logged back in (not just a log back in but after a fresh boot) I got a notification again.
I didn't click neither 'Ignore' nor 'Report' in the notification bubble.

Comment 2 Jakub Filak 2012-12-10 12:33:43 UTC
(In reply to comment #1)
> Actually the issue must be something else. Because I had a crash earlier
> today, 'reported' it to a log file (bug went to the reported bugs list) and
> now that I logged back in (not just a log back in but after a fresh boot) I
> got a notification again.
> I didn't click neither 'Ignore' nor 'Report' in the notification bubble.

Thank you for your comment. That's another bug. If you have time, please file a new bugzilla ticket for this.

Comment 3 Jakub Filak 2012-12-10 13:34:31 UTC
fixed in git

commit c590e3959bebac69619a11fc6742c926b51105cf
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Dec 7 10:13:46 2012 +0100

    abrt-applet: alerts only not reported problems

Comment 4 Sergio 2012-12-10 18:08:28 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Actually the issue must be something else. Because I had a crash earlier
> > today, 'reported' it to a log file (bug went to the reported bugs list) and
> > now that I logged back in (not just a log back in but after a fresh boot) I
> > got a notification again.
> > I didn't click neither 'Ignore' nor 'Report' in the notification bubble.
> 
> Thank you for your comment. That's another bug. If you have time, please
> file a new bugzilla ticket for this.

I didn't because I wasn't able to reproduce it.

Comment 5 Sergio 2012-12-11 13:21:53 UTC
Hi Jakub, it happened today. I had reported a crash to a log file and in a next boot abrt-applet alerted again.
Do you want me to open another bug report or is it fixed already (sorry if I misunderstood)?

Comment 6 Jakub Filak 2012-12-11 13:44:28 UTC
(In reply to comment #5)
> Hi Jakub, it happened today. I had reported a crash to a log file and in a
> next boot abrt-applet alerted again.
> Do you want me to open another bug report or is it fixed already (sorry if I
> misunderstood)?

Hi Sergio,
Yes, please open a new ticket for that. abrt-applet doesn't update its list of already notified problems if you leave the notification bubble to disappear without any user action.

Comment 7 Fedora Update System 2012-12-20 08:55:51 UTC
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18

Comment 8 Fedora Update System 2012-12-20 09:46:11 UTC
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17

Comment 9 Fedora Update System 2012-12-21 01:30:41 UTC
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-01-12 01:17:13 UTC
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-02-26 02:39:18 UTC
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.