Bug 884839 - smokekde 4.9.90-1 is not built with $RPM_*_FLAGS
smokekde 4.9.90-1 is not built with $RPM_*_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smokekde (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks: DebugInfo kde-4.10
  Show dependency treegraph
 
Reported: 2012-12-06 15:15 EST by Ville Skyttä
Modified: 2013-02-25 21:42 EST (History)
6 users (show)

See Also:
Fixed In Version: smokekde-4.10.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 21:42:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 315774 None None None Never

  None (edit)
Description Ville Skyttä 2012-12-06 15:15:25 EST
smokekde 4.9.90-1 is not built with $RPM_*_FLAGS:

http://kojipkgs.fedoraproject.org/packages/smokekde/4.9.90/1.fc19/data/logs/x86_64/build.log

$RPM_OPT_FLAGS were used in 4.9.4-1 so that part is a regression, but neither is built with $RPM_LD_FLAGS, apparently because %cmake_kde4 fails to set $LDFLAGS (see bug 737386).

http://kojipkgs.fedoraproject.org/packages/smokekde/4.9.4/1.fc18/data/logs/x86_64/build.log
Comment 1 Ville Skyttä 2013-02-25 16:40:12 EST
https://bugs.kde.org/show_bug.cgi?id=315774
Comment 2 Rex Dieter 2013-02-25 21:42:41 EST
%changelog
* Mon Feb 25 2013 Rex Dieter <rdieter@fedoraproject.org> 4.10.0-2
- don't override CXXFLAGS (#884839, kde#315774)

Note You need to log in before you can comment on or make changes to this bug.