Bug 884896 - DiskException: no partition specified
DiskException: no partition specified
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:c2391481c78c34c243983c04cbc...
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-06 19:52 EST by Chris Murphy
Modified: 2012-12-14 22:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 22:16:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (409.49 KB, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: environ (885 bytes, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: type (9 bytes, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: storage.log (178.89 KB, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: version (2 bytes, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: program.log (72.28 KB, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: executable (14 bytes, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: product (6 bytes, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: anaconda.log (6.40 KB, text/plain)
2012-12-06 19:52 EST, Chris Murphy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-12-06 19:53 EST, Chris Murphy
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-12-06 19:53 EST, Chris Murphy
no flags Details
File: release (33 bytes, text/plain)
2012-12-06 19:53 EST, Chris Murphy
no flags Details
File: messages (113.41 KB, text/plain)
2012-12-06 19:53 EST, Chris Murphy
no flags Details
File: other involved packages (60 bytes, text/plain)
2012-12-06 19:53 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-12-06 19:52:41 EST
Description of problem:
MBR disk with four partitions: swap, ext4, ext4, xfs. 
1. In Reclaim Space, chose to "Delete" only partition 4 (XFS).
2. Installer allows me to continue forward, back to hub. Shows no errors.
3. Install
Crash.


Version-Release number of selected component:
anaconda-18.36-1.fc18.x86_64

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.36 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 267, in removePartition
:    raise parted.DiskException, "no partition specified"
:  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 32, in new
:    ret = fn(*args, **kwds)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 323, in removePartition
:    self.partedDisk.removePartition(partition)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 1547, in _destroy
:    self.disk.format.removePartition(part)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 819, in destroy
:    self._destroy()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 286, in execute
:    self.device.destroy()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 323, in processActions
:    action.execute()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 336, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 174, in turnOnFilesystems
:    storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 114, in doInstall
:    turnOnFilesystems(storage)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:DiskException: no partition specified
Comment 1 Chris Murphy 2012-12-06 19:52:46 EST
Created attachment 659122 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2012-12-06 19:52:48 EST
Created attachment 659123 [details]
File: environ
Comment 3 Chris Murphy 2012-12-06 19:52:49 EST
Created attachment 659124 [details]
File: type
Comment 4 Chris Murphy 2012-12-06 19:52:51 EST
Created attachment 659125 [details]
File: storage.log
Comment 5 Chris Murphy 2012-12-06 19:52:53 EST
Created attachment 659126 [details]
File: version
Comment 6 Chris Murphy 2012-12-06 19:52:54 EST
Created attachment 659127 [details]
File: program.log
Comment 7 Chris Murphy 2012-12-06 19:52:56 EST
Created attachment 659128 [details]
File: executable
Comment 8 Chris Murphy 2012-12-06 19:52:58 EST
Created attachment 659129 [details]
File: product
Comment 9 Chris Murphy 2012-12-06 19:52:59 EST
Created attachment 659130 [details]
File: anaconda.log
Comment 10 Chris Murphy 2012-12-06 19:53:01 EST
Created attachment 659131 [details]
File: hashmarkername
Comment 11 Chris Murphy 2012-12-06 19:53:03 EST
Created attachment 659132 [details]
File: cmdline_file
Comment 12 Chris Murphy 2012-12-06 19:53:04 EST
Created attachment 659133 [details]
File: release
Comment 13 Chris Murphy 2012-12-06 19:53:06 EST
Created attachment 659134 [details]
File: messages
Comment 14 Chris Murphy 2012-12-06 19:53:07 EST
Created attachment 659135 [details]
File: other involved packages
Comment 15 Chris Murphy 2012-12-06 20:26:30 EST
More info:
1. Is reproducible.
2. The 4th partition specified for deletion has been deleted; there is sufficient installation space.
3. Upon reboot, and relaunching installer, it claims there is enough free space, installation proceeds normally.

Proposing as blocker:
F18 Beta release criterion #9: autopartitioning should be able to use the specified sufficiently sized free space. The "installer shouldn't crash" is part of release criteria #10 for customized partitioning but it seems like this should apply to autopartitioning as well.
Comment 16 Fedora Update System 2012-12-07 20:45:30 EST
anaconda-18.37-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37-1.fc18
Comment 17 Fedora Update System 2012-12-08 17:12:59 EST
Package anaconda-18.37-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37-1.fc18
then log in and leave karma (feedback).
Comment 18 Chris Murphy 2012-12-08 17:19:48 EST
anaconda-18.37-1.fc18 appears to fix this bug.
Comment 19 Reartes Guillermo 2012-12-10 09:01:44 EST
i selected a disk (from a previous f18 multi disk btrfs)  and then  reclaimed space.

i set all to 'delete' except for /boot for which i choose 'shrink' 

anaconda shold not let the user 'shrink' something that can't be shrinked.




Package: anaconda-18.36
OS Release: Fedora release 18-TC1
Comment 20 Adam Williamson 2012-12-10 14:39:17 EST
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . Agreed it's not entirely clear what the trigger for this, cmurf and reartes seem to have had rather different setups. David, can you let us know what the bug is here exactly? Decision on blocker status delayed until we have more data (it may become moot if an update is shipped before next meeting).
Comment 21 David Lehman 2012-12-11 21:59:55 EST
The bug here is that if you do not enter custom storage and remove partitions via the reclaim dialog you'll get this exception because the the fix for 870586.
Comment 22 Fedora Update System 2012-12-12 15:40:21 EST
Package anaconda-18.37.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
then log in and leave karma (feedback).
Comment 23 Chris Murphy 2012-12-12 18:00:20 EST
Bug is still fixed with anaconda-18.37.2-1.fc18.
Comment 24 Fedora Update System 2012-12-14 22:16:21 EST
anaconda-18.37.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.