Bug 884910 - SELinux is preventing /usr/bin/dbus-daemon from 'execute' accesses on the file /usr/bin/gnome-keyring-daemon.
Summary: SELinux is preventing /usr/bin/dbus-daemon from 'execute' accesses on the fil...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1973ccb1a5bf7a802caed4bdca0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-07 02:16 UTC by Eric Blake
Modified: 2012-12-18 06:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-18 06:55:16 UTC
Type: ---


Attachments (Terms of Use)

Description Eric Blake 2012-12-07 02:16:44 UTC
Description of problem:
SELinux is preventing /usr/bin/dbus-daemon from 'execute' accesses on the file /usr/bin/gnome-keyring-daemon.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that dbus-daemon should be allowed execute access on the gnome-keyring-daemon file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gkeyringd_exec_t:s0
Target Objects                /usr/bin/gnome-keyring-daemon [ file ]
Source                        dbus-daemon
Source Path                   /usr/bin/dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.6.8-2.fc18.x86_64
Target RPM Packages           gnome-keyring-3.6.2-2.fc18.x86_64
Policy RPM                    selinux-policy-3.11.1-59.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.6.9-4.fc18.x86_64 #1 SMP Tue Dec
                              4 14:12:51 UTC 2012 x86_64 x86_64
Alert Count                   1
First Seen                    2012-12-06 19:03:45 MST
Last Seen                     2012-12-06 19:03:45 MST
Local ID                      daa2cfdd-b56f-4525-b1ee-76a0630c2358

Raw Audit Messages
type=AVC msg=audit(1354845825.631:405): avc:  denied  { execute } for  pid=2437 comm="dbus-daemon" name="gnome-keyring-daemon" dev="dm-2" ino=158591 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gkeyringd_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1354845825.631:405): arch=x86_64 syscall=execve success=no exit=EACCES a0=11c2d10 a1=11c2c70 a2=11c2df0 a3=7f4113320ad0 items=0 ppid=2434 pid=2437 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=1 comm=dbus-daemon exe=/usr/bin/dbus-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: dbus-daemon,xdm_dbusd_t,gkeyringd_exec_t,file,execute

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t gkeyringd_exec_t:file execute;

audit2allow -R

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t gkeyringd_exec_t:file execute;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.6.9-4.fc18.x86_64
type:           libreport

Potential duplicate: bug 708510

Comment 1 Daniel Walsh 2012-12-07 17:54:56 UTC
Added dontaudit for this 

Fixed in selinux-policy-3.11.1-61.fc18.noarch

Comment 2 Fedora Update System 2012-12-11 17:52:14 UTC
selinux-policy-3.11.1-62.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-62.fc18

Comment 3 Fedora Update System 2012-12-11 23:28:54 UTC
Package selinux-policy-3.11.1-62.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-62.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20203/selinux-policy-3.11.1-62.fc18
then log in and leave karma (feedback).

Comment 4 Gal 2012-12-12 07:27:35 UTC
Tried logging in at the lock screen (system was locked), but keyboard presses weren't registered.
I clicked login as another user, chose my user and it worked.
When I logged in this message popped up but the gnome shell was unresponsive, had to run 'gnom-shell --replace' to unfreeze it.


Package: (null)
OS Release: Fedora release 18 (Spherical Cow)

Comment 5 Fedora Update System 2012-12-17 17:40:37 UTC
selinux-policy-3.11.1-66.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-66.fc18

Comment 6 Fedora Update System 2012-12-18 06:55:17 UTC
selinux-policy-3.11.1-66.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.