Bug 885018 - cannot generate dump file when configure with local path
cannot generate dump file when configure with local path
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 05:04 EST by wanghui
Modified: 2013-02-28 11:46 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-12.el6
Doc Type: Bug Fix
Doc Text:
Previously, when a kernel dump is configured with a local path in Red Hat Enterprise Virtualization Hypervisor 6.4, the dump file failed to be generated. This occured due to the increase in memory requirements of the kdump crash kernel causing out of memory errors when the crash kernel is started. This patch increases the assigned memory size to prevent the out of memory errors. The kernel dump file should correctly generate.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:46:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file (8.58 KB, text/x-log)
2012-12-07 05:04 EST, wanghui
no flags Details

  None (edit)
Description wanghui 2012-12-07 05:04:05 EST
Created attachment 659276 [details]
log file

Description of problem:
there is no dump file in /data/core when configured saving dump file to local through TUI

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121126.0.el6

How reproducible:
90%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.4-20121126.0.el6.
2. Configure the Kernel Dump with Restore(Local) in the TUI.  
3. echo c>/proc/sysrq-trigger to make the system coredump.
4. check the /data/core folder
  
Actual results:
There is no dump file in the /data/core folder since I have tried 5 times.

Expected results:
There is dump file in /data/core folder

Additional info:
1. there is no problem when configure with ssh/nfs.
2. I have tested rhev-hypervisor6-6.3-20121121.0.el6_3 build, and it can generate the local dump file, so it's a regression from 6.3 to 6.4
Comment 6 Fabian Deutsch 2012-12-17 05:23:53 EST
http://gerrit.ovirt.org/#/c/10151/

This patch increases the memory for crashkernels (now at 128M)

Seems as if the kdump  crashkernel requires more mem now ...

Tested as follows:
1. Boot RHEV-H and ensure that the cmdline contains crashkernel=128M
2. Configure kdump with "local"
3. Drop to shell and run echo c > /proc/sysr-trigger
4. Crashkernel boots fine and crashdump appears in /data/core
Comment 8 shaochen 2012-12-24 01:33:04 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.auto1332.el6.

The cmdline contains "crashkernel=128M"
kdump with local can successful, crashkernel boots fine and crashdump appears in /data/core.
Comment 11 shaochen 2013-01-11 03:35:38 EST
Test version:
rhev-hypervisor6-6.4-20130109.1.el6

The cmdline contains "crashkernel=128M"
kdump with local can successful, crashkernel boots fine and crashdump appears in /data/core.

So the bug is fixed, change bug status to VERIFIED.
Comment 13 errata-xmlrpc 2013-02-28 11:46:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.