Bug 885043 - Review Request: seam-solder - A portable CDI extensions library
Summary: Review Request: seam-solder - A portable CDI extensions library
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gerard Ryan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 885039
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-07 10:56 UTC by gil cattaneo
Modified: 2013-01-23 01:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-20 03:37:52 UTC
gerard: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description gil cattaneo 2012-12-07 10:56:20 UTC
Spec URL: http://gil.fedorapeople.org/seam-solder.spec
SRPM URL: http://gil.fedorapeople.org/seam-solder-3.1.1-1.fc16.src.rpm
Description:
A portable CDI extensions library for developing CDI applications,
frameworks or other extensions.

Fedora Account System Username: gil

Comment 1 Gerard Ryan 2012-12-28 16:07:18 UTC
This currently fails to build in mock for both rawhide and f18.

Comment 2 gil cattaneo 2012-12-28 16:12:36 UTC
hi Gerard, may be for a lost builrequires ?
BuildRequires: seam-parent

Comment 3 Gerard Ryan 2012-12-28 16:37:14 UTC
(In reply to comment #2)
> hi Gerard, may be for a lost builrequires ?
> BuildRequires: seam-parent

I think that's the problem for f18, but rawhide has a different problem (since seam-parent is available there). I think this is the relevant snippet from build.log for rawhide:

[ERROR] Failed to execute goal on project solder-api: Could not resolve dependencies for project org.jboss.solder:solder-api:jar:3.1.1.Final: Failed to collect dependencies for [org.jboss.logging:jboss-logging:jar:any (compile), javax.enterprise:cdi-api:jar:latest (provided), org.jboss.spec.javax.servlet:jboss-servlet-api_3.0_spec:jar:latest (provided)]: Failed to read artifact descriptor for javax.annotation:jsr250-api:jar:1.0: The repository system is offline but the artifact org.apache.geronimo.specs:specs:pom:1.4 is not available in the local repository. -> [Help 1]

Comment 4 gil cattaneo 2012-12-28 18:19:14 UTC
ah ok the problem was casued by missing 
BuildRequires: geronimo-parent-poms

this problem is caused by maven-doxia >= 0:1.2-4
M-D was rebuilt with xmvn support and the spec file re-written. this one have lost some requires...
regards
happy new year

Comment 5 Gerard Ryan 2012-12-30 14:31:27 UTC
Ok, I'll review it when you add that to the spec and post new links. :)

Comment 7 Gerard Ryan 2012-12-30 17:12:39 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[-]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in %package
     javadoc
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Apache (v2.0)", "LGPL (v2.1 or later)", "Unknown or generated". 3 files
     have unknown license. Detailed output of licensecheck in
     /home/grdryn/dev/fedora/review/885043-seam-solder/licensecheck.txt

see issue #1 below

[x]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 40960 bytes in 5 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

Java:
[x]: Packages have proper BuildRequires/Requires on jpackage-utils
[x]: Fully versioned dependency in subpackages, if present.
[x]: Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: Javadoc subpackages have Requires: jpackage-utils
[x]: Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlink)
[x]: Bundled jar/class files should be removed before build

Maven:
[x]: Pom files have correct add_maven_depmap call
     Note: Some add_maven_depmap calls found. Please check if they are correct
[x]: Old add_to_maven_depmap macro is not being used
[x]: Packages DOES NOT have Requires(post) and Requires(postun) on jpackage-
     utils for %update_maven_depmap macro
[x]: If package contains pom.xml files install it (including depmaps) even
     when building with ant
[x]: Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: Packages use %{_mavenpomdir} instead of %{_datadir}/maven2/poms

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[x]: SourceX / PatchY prefixed with %{name}.
[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

Java:
[x]: Package has BuildArch: noarch (if possible)
[x]: Package uses upstream build method (ant/maven/etc.)

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Spec file according to URL is the same as in SRPM.
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: seam-solder-3.1.1-1.fc19.src.rpm
          seam-solder-javadoc-3.1.1-1.fc19.noarch.rpm
          seam-solder-3.1.1-1.fc19.noarch.rpm
seam-solder.src: W: invalid-url Source0: seam-solder-3.1.1.Final.tar.xz
3 packages and 0 specfiles checked; 0 errors, 1 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint seam-solder-javadoc seam-solder
2 packages and 0 specfiles checked; 0 errors, 0 warnings.
# echo 'rpmlint-done:'



Requires
--------
seam-solder-javadoc-3.1.1-1.fc19.noarch.rpm (rpmlib, GLIBC filtered):
    
    jpackage-utils

seam-solder-3.1.1-1.fc19.noarch.rpm (rpmlib, GLIBC filtered):
    
    cdi-api
    java
    javassist
    jboss-el-2.2-api
    jboss-logging
    jboss-logging-tools
    jboss-servlet-3.0-api
    jpackage-utils
    log4j
    slf4j



Provides
--------
seam-solder-javadoc-3.1.1-1.fc19.noarch.rpm:
    
    seam-solder-javadoc = 3.1.1-1.fc19

seam-solder-3.1.1-1.fc19.noarch.rpm:
    
    mvn(org.jboss.solder:solder-api) = 3.1.1.Final
    mvn(org.jboss.solder:solder-impl) = 3.1.1.Final
    mvn(org.jboss.solder:solder-parent) = 3.1.1.Final
    mvn(org.jboss.solder:solder-tooling) = 3.1.1.Final
    seam-solder = 3.1.1-1.fc19



MD5-sum check
-------------


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 885043 -m fedora-rawhide-x86_64

Issues:
-------
1. A number of files are licensed under LGPLv2+ , so I think License
field should be ASL 2.0 and LGPLv2+

When this issue is dealt with, I'll approve.

Comment 8 gil cattaneo 2012-12-30 17:51:59 UTC
Spec URL: http://gil.fedorapeople.org/seam-solder.spec
SRPM URL: http://gil.fedorapeople.org/seam-solder-3.1.1-2.fc18.src.rpm

- fixed license field

Comment 9 Gerard Ryan 2012-12-30 19:19:11 UTC
Thanks, I've verified that it has changed. (For anyone else looking at this review, the spec in the 'Spec URL' of the above post hasn't changed, but the spec inside the srpm has the necessary changes).

ACCEPTED.

Comment 10 gil cattaneo 2013-01-09 18:45:46 UTC
New Package SCM Request
=======================
Package Name: seam-solder
Short Description: A portable CDI extensions library
Owners: gil
Branches: f17 f18
InitialCC: java-sig

Comment 11 Gwyn Ciesla 2013-01-09 18:49:54 UTC
Git done (by process-git-requests).

Comment 12 Fedora Update System 2013-01-09 21:50:36 UTC
seam-solder-3.1.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/seam-solder-3.1.1-2.fc18

Comment 13 Fedora Update System 2013-01-09 22:51:16 UTC
seam-solder-3.1.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/seam-solder-3.1.1-2.fc17

Comment 14 Fedora Update System 2013-01-10 21:30:48 UTC
seam-solder-3.1.1-2.fc18 has been pushed to the Fedora 18 testing repository.

Comment 15 Fedora Update System 2013-01-20 03:37:55 UTC
seam-solder-3.1.1-2.fc18 has been pushed to the Fedora 18 stable repository.

Comment 16 Fedora Update System 2013-01-23 01:39:04 UTC
seam-solder-3.1.1-2.fc17 has been pushed to the Fedora 17 stable repository.


Note You need to log in before you can comment on or make changes to this bug.