Bug 885065 - Copy & Paste from Konsole sometimes hoovers up "whitespace to end of line" that doesn't exist
Summary: Copy & Paste from Konsole sometimes hoovers up "whitespace to end of line" th...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: konsole
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-07 12:12 UTC by David Tonhofer
Modified: 2013-06-05 16:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-08 18:46:51 UTC
Type: Bug


Attachments (Terms of Use)
What is being marked (83.69 KB, image/jpeg)
2012-12-07 12:12 UTC, David Tonhofer
no flags Details


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 188528 0 None None None Never

Description David Tonhofer 2012-12-07 12:12:38 UTC
Created attachment 659335 [details]
What is being marked

Description of problem:

- Running Konsole (logged into another machine, not sure whether relevant)
- Run dmidecode generates a large amount of text that scrolls away
- Hunt for a block of text and mark it by left-clicking. If the konsole has a 
  large window, this looks like the attached image.

  At this point, one would expect only the actual text to be copied.

  However:

- Paste the block of text into an editor. Whitespace is added to the
  text as if the original data had had whitespace-filled lines completely
  filling the console window.

Version-Release number of selected component (if applicable):

  konsole-4.9.3-1.fc17.i686

How reproducible:

  Intermittently. Trying to reproduce.

Comment 1 Kevin Kofler 2012-12-08 18:46:51 UTC
This is already reported upstream at bugs.kde.org where it belongs.

Comment 2 David Tonhofer 2013-06-05 16:22:10 UTC
Still occurs in Fedora Spherical Cow F18. 

with konsole-4.10.3-1.fc18.x86_64

But 

https://bugs.kde.org/show_bug.cgi?id=188528

says:

New profile option "Trim trailing spaces" ... 

And it's there! But off by default.


Note You need to log in before you can comment on or make changes to this bug.