Bug 88510 - losetup doesn't support -e option
losetup doesn't support -e option
Status: CLOSED DUPLICATE of bug 56698
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-10 12:28 EDT by Brian G. Anderson
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2003-04-10 12:28:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
"losetup -e aes /dev/loop /var/myfile"

returns "Unsupported encryption type aes".  I've done a modprobe of
cryptoloop, cipher-aes and everything else I can think of.

Of course this will cause the mount command to fail when trying to mount an
encrypted loop filesystem.

I notice that RH8.0 had shipped with a problem where certain utilities--losetup
being one--were not crypto aware even though the stock kernel was compiled with
crypto support.  Is the same problem going on here?

Does RH have some other preferred way of doing encrypted filesystems?  I would
think this is a fairly standard feature.



Version-Release number of selected component (if applicable):
losetup-2.11y-9

How reproducible:
Always

Steps to Reproduce:
1. use dd if=/dev/urandom of=/tmp/crypt bs=1M count=100
2. modprobe cryptoloop cipher-aes
3. losetup -e aes /dev/loop0 /tmp/crypt
    

Actual Results:  Error message: Unsupported encryption type aes

Expected Results:  Should prompt me for a password to build the encrypted loop

Additional info:

There is a similar bug entered for RH8.0 which ultimately refers back to a bug
entered for RH6.2 56698.  All bugs are closed with no indication of why this
isn't fixed.
Comment 1 Nils Philippsen 2003-07-12 09:48:38 EDT

*** This bug has been marked as a duplicate of 56698 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.