Bug 885138 - SRV records "truncated" during zone transfer
Summary: SRV records "truncated" during zone transfer
Keywords:
Status: CLOSED DUPLICATE of bug 829388
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-07 15:15 UTC by Ian Pilcher
Modified: 2013-04-30 23:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-07 15:29:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ian Pilcher 2012-12-07 15:15:28 UTC
I have set up a 32-bit RHEL 6.3 VM as an identity management server, including 
bind-dyndb-ldap-1.1.0-0.9.b1.el6_3.1.i686.

The server responds correctly to simple SRV queries:

[root@ipa ~]# dig @localhost _ntp._udp.rhev.icp.selfip.net srv

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.5 <<>> @localhost _ntp._udp.rhev.icp.selfip.net srv
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14090
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;_ntp._udp.rhev.icp.selfip.net. IN      SRV

;; ANSWER SECTION:
_ntp._udp.rhev.icp.selfip.net. 86400 IN SRV     0 100 123 ipa.rhev.icp.selfip.net.

;; AUTHORITY SECTION:
rhev.icp.selfip.net.    86400   IN      NS      ipa.rhev.icp.selfip.net.
rhev.icp.selfip.net.    86400   IN      NS      asterisk.icp.selfip.net.

;; ADDITIONAL SECTION:
ipa.rhev.icp.selfip.net. 1200   IN      A       172.31.249.201

;; Query time: 16 msec
;; SERVER: ::1#53(::1)
;; WHEN: Fri Dec  7 09:12:03 2012
;; MSG SIZE  rcvd: 143

During a zone transfer, however, the SRV records are "truncated"; only the short hostname is sent, rather than the FQDN:

[root@asterisk ~]# dig @ipa.rhev.icp.selfip.net rhev.icp.selfip.net axfr
                                                                                                     
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.6 <<>> @ipa.rhev.icp.selfip.net rhev.icp.selfip.net axfr
; (1 server found)                                                                                               
;; global options: +cmd                                                                                          
rhev.icp.selfip.net.    86400   IN      SOA     ipa.rhev.icp.selfip.net. hostmaster.rhev.icp.selfip.net. 2012111302 3600 900 1209600 3600
rhev.icp.selfip.net.    86400   IN      NS      ipa.rhev.icp.selfip.net.                                              
rhev.icp.selfip.net.    86400   IN      NS      asterisk.icp.selfip.net.                                                 
ipa.rhev.icp.selfip.net. 1200   IN      A       172.31.249.201                                                             
ipa.rhev.icp.selfip.net. 1200   IN      SSHFP   2 1 DD9DC54E358CB48617F6A44ACFE43525EB102BE4                                    
ipa.rhev.icp.selfip.net. 1200   IN      SSHFP   1 1 3D64F3E2160164385F978411AE40B30B59393D92                                         
_ldap._tcp.rhev.icp.selfip.net. 86400 IN SRV    0 100 389 ipa.                                                                         
_kerberos.rhev.icp.selfip.net. 86400 IN TXT     "RHEV.ICP.SELFIP.NET"                                                                   
_kerberos._tcp.rhev.icp.selfip.net. 86400 IN SRV 0 100 88 ipa.                                                                            
_kerberos._udp.rhev.icp.selfip.net. 86400 IN SRV 0 100 88 ipa.                                                                            
_kerberos-master._tcp.rhev.icp.selfip.net. 86400 IN SRV 0 100 88 ipa.                                                                      
_kerberos-master._udp.rhev.icp.selfip.net. 86400 IN SRV 0 100 88 ipa.                                                                       
_kpasswd._tcp.rhev.icp.selfip.net. 86400 IN SRV 0 100 464 ipa.
_kpasswd._udp.rhev.icp.selfip.net. 86400 IN SRV 0 100 464 ipa.
_ntp._udp.rhev.icp.selfip.net. 86400 IN SRV     0 100 123 ipa.
hyp1.rhev.icp.selfip.net. 86400 IN      A       172.31.249.1
hyp2.rhev.icp.selfip.net. 86400 IN      A       172.31.249.2
mgr.rhev.icp.selfip.net. 86400  IN      A       172.31.249.200
cds1.rhev.icp.selfip.net. 86400 IN      A       172.31.249.203
cds2.rhev.icp.selfip.net. 86400 IN      A       172.31.249.204
rhua.rhev.icp.selfip.net. 86400 IN      A       172.31.249.202
rhev.icp.selfip.net.    86400   IN      SOA     ipa.rhev.icp.selfip.net. hostmaster.rhev.icp.selfip.net. 2012111302 3600 900 1209600 3600
;; Query time: 38 msec
;; SERVER: 172.31.249.201#53(172.31.249.201)
;; WHEN: Fri Dec  7 09:14:40 2012
;; XFR size: 22 records (messages 1, bytes 689)

Comment 1 Petr Spacek 2012-12-07 15:29:45 UTC

*** This bug has been marked as a duplicate of bug 829388 ***


Note You need to log in before you can comment on or make changes to this bug.