Bug 885170 - Need to provide translated error message for hosts registering to RHN Hosted.
Need to provide translated error message for hosts registering to RHN Hosted.
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On:
Blocks: 885221 space19
  Show dependency treegraph
 
Reported: 2012-12-07 11:30 EST by Stephen Herr
Modified: 2013-03-06 13:34 EST (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.9.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 885221 (view as bug list)
Environment:
Last Closed: 2013-03-06 13:34:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2012-12-07 11:30:30 EST
If a client tool tries to register to RHN Hosted and the registration is denied we need to catch the error and display a nice translated message to the user explaining the situation.

Hosted will return error 72 in this case. We display a translated message that is similar to:


"Red Hat Network Classic is not supported. To register with Red Hat Subscription Management please run:

subscription-manager register --auto-attach

Get more information at access.redhat.com/knowledge"
Comment 1 Stephen Herr 2012-12-07 13:58:35 EST
We need to change that to error 74, Satellites already have an error 72.
Comment 2 Stephen Herr 2012-12-07 14:36:55 EST
Committed to Spacewalk master: 3856179a57bd4a237cc6221a03ce59e0d159df06
Comment 3 Jan Pazdziora 2012-12-10 04:48:54 EST
One more fix needed in Spacewalk master: bf8ad23de280742d707cd54f9ff65ad40e153ad0.
Comment 6 Stephen Herr 2013-03-01 12:07:32 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 7 Stephen Herr 2013-03-06 13:34:56 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.