Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 885241 - RPM specific install doco refers to a non-existent file
Summary: RPM specific install doco refers to a non-existent file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mediawiki119
Version: el6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Patrick Uiterwijk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-07 21:35 UTC by R P Herrold
Modified: 2013-05-17 22:17 UTC (History)
4 users (show)

Fixed In Version: mediawiki119-1.19.6-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-17 22:17:47 UTC
Type: Bug


Attachments (Terms of Use)

Description R P Herrold 2012-12-07 21:35:01 UTC
Description of problem:

The file:
   /usr/share/doc/mediawiki119-1.19.1/README.RPM

states:

4) allow write access to /var/www/mediawiki119/config by:

   chmod a+w /var/www/mediawiki119/config

but the file does not exist

[root@centos-6 ~]# chmod a+w /var/www/mediawiki119/config
chmod: cannot access `/var/www/mediawiki119/config': No such file or directory
[root@centos-6 ~]# rpm -ql mediawiki119 | grep config$
/usr/share/mediawiki119/mw-config
/var/www/mediawiki119/mw-config
/var/www/mediawiki119/mw-config/mw-config


I suspect the mw-prefixed file is expected, but ...

[root@centos-6 ~]# ls /var/www/mediawiki119/
api.php     images     languages    opensearch_desc.php  skins
cache       includes   maintenance  resources
extensions  index.php  mw-config    serialized
[root@centos-6 ~]#



Version-Release number of selected component (if applicable):

mediawiki119-1.19.1-1

How reproducible:

install package and read the doco file

Steps to Reproduce:

step 4 refers to a non-existent file
  
Actual results:

doco does not help
as above

Expected results:

accurate instructions


Additional info:

Comment 1 R P Herrold 2012-12-07 21:36:35 UTC
looking further, mw-config seems to be a sym link:

lrwxrwxrwx. 1 root root   33 Dec  7 15:17 mw-config -> /usr/share/mediawiki119/mw-config

Comment 2 R P Herrold 2012-12-07 21:42:46 UTC
I note that there is a security update and later 1.20 mediawiki out there.

Comment 3 Stephen John Smoogen 2012-12-07 22:15:21 UTC
Hi RP

We are rolling out 1.19.3 as soon as we can.. but will not be doing 1.20 in EPEL due to it has a 6 month lifetime before 1.21 is put out. 1.19 is supposed to stay fresh until the current Debian release ends (or 2 years which ever comes first :)).. so I am going to keep on that until the next LTS is out.

Will fix the mw-config issue in the 1.19.3 update.

Comment 4 Patrick Uiterwijk 2013-04-19 08:52:13 UTC
This has been delayed some, but will be submitted after the 1.19.5-1 security update is pushed to stable (so in about two weeks from now).

Comment 5 Fedora Update System 2013-05-03 08:49:20 UTC
mediawiki119-1.19.6-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-5649/mediawiki119-1.19.6-1.el6

Comment 6 R P Herrold 2013-05-06 22:27:33 UTC
not fixed -- 

[root@centos-6 ~]# ls -al /var/www/mediawiki119/config
ls: cannot access /var/www/mediawiki119/config: No such file or directory
[root@centos-6 ~]# ls -al /var/www/mediawiki119/ | grep config
drwxr-xr-x. 2 root root 4096 May  6 18:25 mw-config
[root@centos-6 ~]# rpm -q mediawiki119
mediawiki119-1.19.5-1.el6.noarch
[root@centos-6 ~]#

no file to harden RO is there, even still

Expected results:

accurate instructions

Comment 7 R P Herrold 2013-05-06 22:29:26 UTC
[root@centos-6 ~]# grep config   /usr/share/doc/mediawiki119-1.19.5/README.RPM                                                                      
 
4) allow write access to /var/www/mediawiki119/config by:
   chmod a+w /var/www/mediawiki119/config


8) disable write access to /var/www/mediawiki119/config by:
   chmod a-w /var/www/mediawiki119/config

... etc

Comment 8 Patrick Uiterwijk 2013-05-07 10:06:00 UTC
Please note that your rpm -q mediawiki119 reports mediawiki119-1.19.5-1.el6.noarch, while, as reported by the update system, this has been fixed in mediawiki119-1.19.6-1.el6.noarch.

This update is not yet in the stable repositories, but should land somewhere in the next two weeks, at which point this bug will automatically be updated.
If you require the new version now, you should be able to retrieve it by running yum update mediawiki119 --enablerepo=epel-testing .

Comment 9 R P Herrold 2013-05-07 19:57:56 UTC
ahh --- I missed that an update did not catch the new candidate .. will look.  Thank you

Comment 10 Fedora Update System 2013-05-17 22:17:47 UTC
mediawiki119-1.19.6-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.