Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 885274 - SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'execute' accesses on the file /home/carlos/gnome/install/lib64/libgobject-2.0.so.0.3503.0.
Summary: SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'execute' ac...
Keywords:
Status: CLOSED DUPLICATE of bug 885265
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e212075bf8a02e30fe5848e2a06...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-08 01:54 UTC by Carlos Soriano
Modified: 2012-12-10 08:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-10 08:38:42 UTC
Type: ---


Attachments (Terms of Use)

Description Carlos Soriano 2012-12-08 01:54:32 UTC
Description of problem:
Opening a video, plugin container failed due to selinux.
SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'execute' accesses on the file /home/carlos/gnome/install/lib64/libgobject-2.0.so.0.3503.0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that plugin-container should be allowed execute access on the libgobject-2.0.so.0.3503.0 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /home/carlos/gnome/install/lib64/libgobject-2.0.so
                              .0.3503.0 [ file ]
Source                        plugin-containe
Source Path                   /usr/lib64/xulrunner/plugin-container
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xulrunner-17.0.1-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-60.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.6.9-4.fc18.x86_64 #1 SMP Tue Dec
                              4 14:12:51 UTC 2012 x86_64 x86_64
Alert Count                   1
First Seen                    2012-12-08 02:53:13 CET
Last Seen                     2012-12-08 02:53:13 CET
Local ID                      1a30ab13-8c3e-48a4-b658-f3b919892390

Raw Audit Messages
type=AVC msg=audit(1354931593.271:628): avc:  denied  { execute } for  pid=2037 comm="plugin-containe" path="/home/carlos/gnome/install/lib64/libgobject-2.0.so.0.3503.0" dev="dm-2" ino=36841095 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1354931593.271:628): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=24ef78 a2=5 a3=802 items=0 ppid=1946 pid=2037 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/xulrunner/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-containe,mozilla_plugin_t,user_home_t,file,execute

audit2allow

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_t:file execute;

audit2allow -R

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_t:file execute;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.6.9-4.fc18.x86_64
type:           libreport

Potential duplicate: bug 827678

Comment 1 Miroslav Grepl 2012-12-10 08:38:42 UTC

*** This bug has been marked as a duplicate of bug 885265 ***


Note You need to log in before you can comment on or make changes to this bug.