This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 885284 - grub is not installed in an all defaults autopart installation, system not bootable
grub is not installed in an all defaults autopart installation, system not bo...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-08 01:31 EST by Chris Murphy
Modified: 2013-10-31 08:02 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-18.37.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 22:17:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.47 KB, text/plain)
2012-12-08 01:38 EST, Chris Murphy
no flags Details
anaconda.program.log (78.99 KB, text/plain)
2012-12-08 01:39 EST, Chris Murphy
no flags Details
anaconda.storage.log (133.69 KB, text/plain)
2012-12-08 01:40 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-12-08 01:31:02 EST
Description of problem:
grub is not installed to the MBR and MBR gap in a normal autopart installation. Resulting system it not bootable.

Version-Release number of selected component (if applicable):
Fedora-18-TC1-x86_64-Live-Desktop.iso with anaconda 18.37-1 from koji


How reproducible:
Always

Steps to Reproduce:
1. Started with a single blank virtual disk image. 
2. Proceed with an all defaults autopart installation.
3. Reboot upon successful completion.
  
Actual results:
System is not bootable.
MBR boot loader region contains garbage, not GRUB code; MBR gap is empty.

Expected results:
A bootable system.

Additional info:
Comment 1 Chris Murphy 2012-12-08 01:38:29 EST
Created attachment 659749 [details]
anaconda.log
Comment 2 Chris Murphy 2012-12-08 01:39:47 EST
Created attachment 659750 [details]
anaconda.program.log
Comment 3 Chris Murphy 2012-12-08 01:40:32 EST
Created attachment 659751 [details]
anaconda.storage.log
Comment 4 Chris Murphy 2012-12-08 01:43:37 EST
program.log is missing a grub2-install, grub2-mkconfig, etc. entries.

storage.log bogus claim: 01:13:58,924 INFO storage: user specified that bootloader install be skipped

anaconda.log: 01:19:02,896 INFO anaconda: Installing bootloader
Comment 5 Steve Tyler 2012-12-08 03:14:18 EST
Confirmed. Installed system hangs at:
Booting from Hard Disk...

Tested with:
$ qemu-img create f18-test-1.img 12G
$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Final/TC1/Fedora-18-TC1-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse

Updated anaconda on Live CD from koji: 
Information for build anaconda-18.37-1.fc18
ID	371688

Installed with default storage configuration:
Click Installation Destination.
Click Done.
Click Begin Installation.
Comment 6 Steve Tyler 2012-12-08 04:09:03 EST
A workaround is to toggle installing the bootloader off and then on:

Click Installation Destination.
Click Full disk summary and options...
Click ATA QEMU HARDDISK to select.
Click Do not install bootloader.
Click Set as Boot Device.
Click Close.
Click Done.
Click Begin Installation.
Comment 7 Kamil Páral 2012-12-11 09:37:51 EST
Confirmed with smoke5. Happens for uninitialized disks. Proposing as blocker.
Comment 8 Fedora Update System 2012-12-11 19:54:14 EST
anaconda-18.37.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
Comment 9 Adam Williamson 2012-12-12 12:27:19 EST
Discussed at 2012-12-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt . Accepted as a blocker per criterion "In most cases, a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode..."
Comment 10 Fedora Update System 2012-12-12 15:41:04 EST
Package anaconda-18.37.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
then log in and leave karma (feedback).
Comment 11 Chris Murphy 2012-12-12 17:44:30 EST
anaconda-18.37.2-1.fc18 fixes this bug for me. Grub is installed.
Comment 12 Adam Williamson 2012-12-12 20:22:20 EST
smoke6 seems fine for me too, I got grub.
Comment 13 Fedora Update System 2012-12-14 22:17:21 EST
anaconda-18.37.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.