Bug 885286 - [abrt] ibus-libpinyin-1.4.93-4.fc17: Process /usr/libexec/ibus-engine-libpinyin was killed by signal 11 (SIGSEGV)
Summary: [abrt] ibus-libpinyin-1.4.93-4.fc17: Process /usr/libexec/ibus-engine-libpiny...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8392de0147ad5a1d9c12b545896...
: 885287 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-08 07:31 UTC by Chen_Min_Chin
Modified: 2013-01-12 00:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-23 03:58:26 UTC
Type: ---


Attachments (Terms of Use)
File: core_backtrace (2.01 KB, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: environ (731 bytes, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: backtrace (18.06 KB, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: cgroup (127 bytes, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: smolt_data (3.18 KB, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: executable (34 bytes, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: maps (8.59 KB, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: dso_list (2.76 KB, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: proc_pid_status (798 bytes, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: open_fds (429 bytes, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details
File: var_log_messages (271 bytes, text/plain)
2012-12-08 07:31 UTC, Chen_Min_Chin
no flags Details

Description Chen_Min_Chin 2012-12-08 07:31:01 UTC
Version-Release number of selected component:
ibus-libpinyin-1.4.93-4.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-engine-libpinyin --ibus
crash_function: pinyin::PinyinLookup2::save_next_step
kernel:         3.6.9-2.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 pinyin::PinyinLookup2::save_next_step at pinyin_lookup2.cpp:457
: #1 pinyin::PinyinLookup2::bigram_gen_next_step at pinyin_lookup2.cpp:438
: #2 pinyin::PinyinLookup2::search_bigram2 at pinyin_lookup2.cpp:371
: #3 pinyin::PinyinLookup2::get_best_match at pinyin_lookup2.cpp:265
: #4 pinyin_guess_sentence at pinyin.cpp:612
: #5 PY::LibPinyinBopomofoEditor::insert at PYPBopomofoEditor.cc:72
: #6 PY::LibPinyinBopomofoEditor::processKeyEvent at PYPBopomofoEditor.cc:203
: #7 PY::LibPinyinBopomofoEngine::processKeyEvent at PYPBopomofoEngine.cc:108
: #8 _ibus_marshal_BOOLEAN__UINT_UINT_UINT at ibusmarshalers.c:290
: #14 ibus_engine_service_method_call at ibusengine.c:816

Comment 1 Chen_Min_Chin 2012-12-08 07:31:05 UTC
Created attachment 659752 [details]
File: core_backtrace

Comment 2 Chen_Min_Chin 2012-12-08 07:31:07 UTC
Created attachment 659753 [details]
File: environ

Comment 3 Chen_Min_Chin 2012-12-08 07:31:09 UTC
Created attachment 659754 [details]
File: limits

Comment 4 Chen_Min_Chin 2012-12-08 07:31:11 UTC
Created attachment 659755 [details]
File: backtrace

Comment 5 Chen_Min_Chin 2012-12-08 07:31:13 UTC
Created attachment 659756 [details]
File: cgroup

Comment 6 Chen_Min_Chin 2012-12-08 07:31:15 UTC
Created attachment 659757 [details]
File: smolt_data

Comment 7 Chen_Min_Chin 2012-12-08 07:31:17 UTC
Created attachment 659758 [details]
File: executable

Comment 8 Chen_Min_Chin 2012-12-08 07:31:19 UTC
Created attachment 659759 [details]
File: maps

Comment 9 Chen_Min_Chin 2012-12-08 07:31:21 UTC
Created attachment 659760 [details]
File: dso_list

Comment 10 Chen_Min_Chin 2012-12-08 07:31:24 UTC
Created attachment 659761 [details]
File: proc_pid_status

Comment 11 Chen_Min_Chin 2012-12-08 07:31:26 UTC
Created attachment 659762 [details]
File: open_fds

Comment 12 Chen_Min_Chin 2012-12-08 07:31:28 UTC
Created attachment 659763 [details]
File: var_log_messages

Comment 13 Peng Wu 2012-12-12 05:27:23 UTC
*** Bug 885287 has been marked as a duplicate of this bug. ***

Comment 14 Peng Wu 2012-12-12 05:39:02 UTC
Wrote a patch for libpinyin to add a safe guard for chewing input.

Comment 15 Fedora Update System 2012-12-12 06:10:14 UTC
libpinyin-0.8.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libpinyin-0.8.0-2.fc18

Comment 16 Fedora Update System 2012-12-12 06:10:26 UTC
libpinyin-0.8.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libpinyin-0.8.0-2.fc17

Comment 17 Fedora Update System 2012-12-12 20:43:29 UTC
Package libpinyin-0.8.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpinyin-0.8.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20260/libpinyin-0.8.0-2.fc18
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2012-12-23 03:58:28 UTC
libpinyin-0.8.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2013-01-12 00:42:43 UTC
libpinyin-0.8.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.